lkml.org 
[lkml]   [2000]   [Oct]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectHard lock with Raid 0.90 on buslogic flashpoint SCSI card
Date

I hope this is going to the right list/group/etc, as I got this email
address from someone on #kernelnewbies...

Attempting to mkraid /dev/md0 a raid5 array using a Buslogic Flashpoint
fast SCSI PCI card will always hard lock the system at exactly 2% complete.
There is no oops or log, and it's a total lockup. I can't even switch
virtual terminals when it locks. Using an AHA-2940UW in place of the
buslogic works perfectly.

This is using kernel 2.2.17 with the raid 0.90 B0 patch which applied
cleanly. I was wondering if it was raid, but since the 2940 worked, I
started to wonder about the Buslogic card driver maybe.

root@userhost:~# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid5]
read_ahead 1024 sectors
md0 : active raid5 sdd1[2] sdc1[1] sdb1[0] 4185856 blocks level 5, 4k chunk,
alg
orithm 0 [3/3] [UUU] resync=68% finish=17.8min
unused devices: <none>
root@userhost:~#

A cut-and-paste of the rebuild in progress. It completed normally and
was usable after that on the 2940. I will test any other variations of
tests I can think of and give the results.

Any information on even how I can troubleshoot this further would be
appreciated!

For replies (If this is a mailing list), please cc: me as well, as I am
not on the mailing list.

Diamon

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.098 / U:1.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site