lkml.org 
[lkml]   [2000]   [Oct]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.0-test9-pre8


On Tue, 3 Oct 2000, Rik van Riel wrote:

> On Tue, 3 Oct 2000, Martin Diehl wrote:
>
> > * deadlock in initscripts (even for runlevel 2). SysRq shows idle_task
> > being the only one ever getting the CPU when deadlocked.
>
> This suggests tasks yielding the CPU while task->state !=
> TASK_RUNNABLE, which results in them never being rescheduled
> again ...

Just tried 2.4.0-t9p8 + t9p8-vmpatch: No change here. Box appears
to hang upon "init 2" (or higher) when starting several things (sendmail,
xfs e.g.) with (according to SysRq+p) idle_task being the only one R.
However, if I just wait for some 15 minutes or so it finally reaches
the console login prompt - but I'm unable to login, since this seems
to require the same duration, so the login timeout is killing me.
Things seem to speed up, when *continously* pressing SysRq+[tpm]:
Besides screen scrolling there is some minor disk activity, but always
EIP in idle_task. Looks similar to what somebody else reported.
Problem appeares for the first time when switching from vanilla t9p7 to
t9p8+t9p[78]-vmpatch (Haven't tried vanilla t9p[89]).
Will try 2.4.0-test9 (final).

> (time to hunt down the rescheduling points)

Willing to try the patch for this when available.

Regards,
Martin

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.110 / U:0.488 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site