lkml.org 
[lkml]   [2000]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] 2.4 Changes update (was Re: [patch] kernel/module.c)
Date
[I accidentally sent the message to vger.rutgers.edu the first time. Sorry.]

Linus Torvalds wrote:

> It seems that gcc-2.7.2.3 is terminally ill. I'd rather change
> Documentation/Changes, and just document the fact.

FWIW, here's a patch that does that. It also fixes a typo ("IA/32" should
be "IA-32") and clarifies that the Documentation/Changes comments about gcc
versions apply mainly to x86.

If I made any mistakes, please correct me...

-Barry K. Nathan <barryn@pobox.com>

--- linux-2.4.0test10pre5/Documentation/Changes Mon Oct 23 20:20:31 2000
+++ linux-2.4.0test10pre5-bkn/Documentation/Changes Tue Oct 24 20:57:13 2000
@@ -31,7 +31,7 @@
Eine deutsche Version dieser Datei finden Sie unter
<http://www.stefan-winter.de/Changes-2.4.0.txt>.

-Last updated: October 13, 2000
+Last updated: October 24, 2000

Chris Ricker (kaboom@gatech.edu or chris.ricker@genetics.utah.edu).

@@ -48,7 +48,7 @@
Card) hardware, for example, you probably needn't concern yourself
with pcmcia-cs.

-o Gnu C 2.7.2.3 # gcc --version
+o Gnu C 2.91.66 # gcc --version
o Gnu make 3.77 # make --version
o binutils 2.9.1.0.25 # ld -v
o util-linux 2.10o # kbdrate -v
@@ -64,13 +64,23 @@
GCC
---

-You will need at least gcc 2.7.2 to compile the kernel. You currently
-have several options for gcc-derived compilers: gcc 2.7.2.3, various
-versions of egcs, the new gcc 2.95 and upcoming gcc 3.0, and experimental
-compilers like pgcc. For absolute stability, it is still recommended
-that gcc 2.7.2.3 be used to compile your kernel. egcs 1.1.2 should also
-work. gcc 2.95 is known to have problems, and using pgcc for your kernel
-is just asking for trouble.
+The gcc version requirements may vary depending on the type of CPU in your
+computer. The next paragraph applies to users of x86 CPUs, but not
+necessarily to users of other CPUs. Users of other CPUs should obtain
+information about their gcc version requirements from another source.
+
+The recommended compiler for the kernel is egcs 1.1.2 (gcc 2.91.66), and it
+should be used when you need absolute stability. You may use gcc 2.95.2
+instead if you wish, although it may cause problems. Later versions of gcc
+have not received much testing for Linux kernel compilation, and there are
+almost certainly kernel bugs that will need to be fixed for these
+compilers. In any case, using pgcc instead of egcs or plain gcc is just
+asking for trouble.
+
+Note that gcc 2.7.2.3 is no longer supported. Linux kernel 2.4, unlike
+previous releases, does not work around gcc 2.7.2.3's bugs. Attempting to
+compile kernel 2.4 with this version of gcc will most likely result in a
+compilation error or in a miscompiled kernel.

In addition, please pay attention to compiler optimization. Anything
greater than -O2 may not be wise. Similarly, if you choose to use gcc-2.95
@@ -85,7 +95,7 @@
Binutils
--------

-Linux on IA/32 has recently switched from using as86 to using gas for
+Linux on IA-32 has recently switched from using as86 to using gas for
assembling the 16-bit boot code, removing the need for as86 to compile
your kernel. This change does, however, mean that you need a recent
release of binutils.
@@ -244,11 +254,6 @@

Compilers
*********
-
-gcc 2.7.2.3
------------
-o <ftp://ftp.gnu.org/gnu/gcc/gcc-2.7.2.3.tar.gz>
-o <ftp://metalab.unc.edu/pub/gnu/gcc-2.7.2.3.tar.gz>

egcs 1.1.2
---------
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.087 / U:8.476 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site