lkml.org 
[lkml]   [2000]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjecta strange behaviour in kernels...
Hello,

I hope I'm sending this email to the right people, otherwise excuse me
please and forward it.
Here is my problem:

My computer is a Compaq proliant ML350 with a smart controler ultra2
wide scsi.
I installed the redhat 6.2 with a kernel 2.2.13 (but the problem occurs
even with 2.2.17),
the total memory amount is 512MO.
If I wish to copy some very big files from a directory to another (about
8 GO files for example),
or from another computer to this computer threw network (10Mb/s),
the copy starts, then the amount of available memory becomes very short
because quite the whole
memory become used as buffer for data transfer, then processes have no
memory enough to run,
the system becomes very slow because of swaping, then the data transfer
crashes.
Then when data transfer stops, buffers allocated are not released
easily, the system still remains
slow as if it took time too much as searching in a so huge buffer.
I tried to transfer data from the first computer, threw network, to a
tape (DLT) it seems work
better but the problem of disk buffer is still not resolved. I wish to
migrate my data into Oracle 8i
for Linux on this computer, but I'm afraid because of this problem which
could loose some data.
So are there any parameter which could be changed in source kernel, or
any patch which could
help me to limit the amount of memory allocated for disks transfers?
Thanks for a quick reply, we just received this new computer and need to
resolve that very soon.
Best Regards.

Georges Poropat.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.022 / U:0.192 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site