lkml.org 
[lkml]   [2000]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[patch] 2.4.0-test10-pre5 check for acceptable gcc
Date
torvalds wrote
>It seems that gcc-2.7.2.3 is terminally ill. I'd rather change
>Documentation/Changes, and just document the fact.
>These kinds of subtle work-arounds for gcc bugs are not really acceptable,
>nor is it worthwhile complaining when somebody does development with a gcc
>that is _not_ broken, and doesn't notice that some random gcc bug breaks
>the kernel for others.

Index: 0-test10-pre5.1/init/main.c
--- 0-test10-pre5.1/init/main.c Sat, 23 Sep 2000 11:16:56 +1100 kaos (linux-2.4/j/46_main.c 1.1.2.2.1.1.2.5.1.2.1.1.2.1 644)
+++ 0-test10-pre5.1(w)/init/main.c Wed, 25 Oct 2000 21:29:02 +1100 kaos (linux-2.4/j/46_main.c 1.1.2.2.1.1.2.5.1.2.1.1.2.1 644)
@@ -73,7 +73,7 @@ extern void nubus_init(void);
* To avoid associated bogus bug reports, we flatly refuse to compile
* with a gcc that is known to be too old from the very beginning.
*/
-#if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 7)
+#if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 91)
#error sorry, your GCC is too old. It builds incorrect kernels.
#endif

Index: 0-test10-pre5.1/Documentation/Changes
--- 0-test10-pre5.1/Documentation/Changes Thu, 19 Oct 2000 11:08:42 +1100 kaos (linux-2.4/G/c/25_Changes 1.1.1.4.1.5 644)
+++ 0-test10-pre5.1(w)/Documentation/Changes Wed, 25 Oct 2000 21:32:48 +1100 kaos (linux-2.4/G/c/25_Changes 1.1.1.4.1.5 644)
@@ -48,7 +48,7 @@ necessary on all systems; obviously, if
Card) hardware, for example, you probably needn't concern yourself
with pcmcia-cs.

-o Gnu C 2.7.2.3 # gcc --version
+o Gnu C 2.91.66 # gcc --version
o Gnu make 3.77 # make --version
o binutils 2.9.1.0.25 # ld -v
o util-linux 2.10o # kbdrate -v
@@ -64,13 +64,13 @@ Kernel compilation
GCC
---

-You will need at least gcc 2.7.2 to compile the kernel. You currently
-have several options for gcc-derived compilers: gcc 2.7.2.3, various
+You will need at least gcc 2.91 to compile the kernel. You currently
+have several options for gcc-derived compilers: gcc 2.91.66, various
versions of egcs, the new gcc 2.95 and upcoming gcc 3.0, and experimental
compilers like pgcc. For absolute stability, it is still recommended
-that gcc 2.7.2.3 be used to compile your kernel. egcs 1.1.2 should also
-work. gcc 2.95 is known to have problems, and using pgcc for your kernel
-is just asking for trouble.
+that gcc 2.91.66 be used to compile your kernel (also known as egcs
+1.1.2). gcc 2.95 is known to have problems, and using pgcc for your
+kernel is just asking for trouble.

In addition, please pay attention to compiler optimization. Anything
greater than -O2 may not be wise. Similarly, if you choose to use gcc-2.95
@@ -245,12 +245,7 @@ Getting updated software
Compilers
*********

-gcc 2.7.2.3
------------
-o <ftp://ftp.gnu.org/gnu/gcc/gcc-2.7.2.3.tar.gz>
-o <ftp://metalab.unc.edu/pub/gnu/gcc-2.7.2.3.tar.gz>
-
-egcs 1.1.2
+gcc 2.91.66 (egcs 1.1.2)
---------
o <ftp://ftp.valinux.com/pub/support/hjl/gcc/egcs-1.1.2/egcs-1.1.2-glibc.x86.tar.bz2>
o <ftp://ftp.valinux.com/pub/support/hjl/gcc/egcs-1.1.2/egcs-1.1.2-libc5.x86.tar.bz2>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.024 / U:1.364 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site