lkml.org 
[lkml]   [2000]   [Oct]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectregarding fsck
Hi,
I am getting a kernel panic when I boot linux.
There is some bad block.
To get rid of this, I want to run fsck.I boot linux
with a boot diskette and then with rescue.img I get
to the command prompt and then run fsck.
#e2fsck /dev/hdb5 //hdb5 is my linux native

when I run fsck I get following message:

Group decriptors look bad... trying backup block...
e2fsck:Bad magic number in superblock while trying
to open /dev/hdb5
The superblock could not be read or does not
describe a correct ext2 filesystem.If the device is
valid and it really contains ext2 filesystem(and not
swap or ufs or something else), then the superblock is
corrupt, and you might try running e2fsck with an
alternative superblock: e2fsck -b 8193 <device>

I run
#e2fsck -b 8193 /dev/hdb5
I get the same message as I got above.

How can I get my linux back?


with regards,
Anil





__________________________________________________
Do You Yahoo!?
Yahoo! Messenger - Talk while you surf! It's FREE.
http://im.yahoo.com/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.022 / U:28.284 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site