lkml.org 
[lkml]   [2000]   [Oct]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectIntel ICH audio problems
Hi all,

I'm having problems getting Intel ICH audio driver working
properly. It plays MP3's like 1.5-2x faster than normal.

lspci -n:
00:1f.5 Class 0401: 8086:2445 (rev 01)

It's an AC97-compatible embedded soundchip
(SoundMAX audio) in a Compaq Deskpro EN .. intel i810 chipset.

In 2.4-test10-pre4:
kernel: Intel 810 + AC97 Audio, version 0.01, 16:08:46
kernel: PCI: Setting latency timer of device 00:1f.5 to 64
kernel: i810: Intel ICH2 found at IO 0x2400 and 0x2000, IRQ 5

In 2.2.18pre16:

kernel: Intel 810 + AC97 Audio, version 0.17, 10:02:29 Oct 18 2000
kernel: PCI: Increasing latency timer of device 00:fd to 64
kernel: i810: Intel ICH2 found at IO 0x2400 and 0x2000, IRQ 5
kernel: ac97_codec: AC97 Audio codec, vendor id1: 0x4144, id2: 0x5360
(Analog Devices AD1885)
kernel: i810_audio: Found 1 audio device(s).

In 2.4, sound doesn't even play.
In 2.2.18pre16, sound plays quite fast (1.5x-2x faster).
Is there a tweak for this?

Please direct all replies to my e-mail address
(freyason@yahoo.com), as I am not actually subscribed to the
linux-kernel list.

Thanks!
Tom

__________________________________________________
Do You Yahoo!?
Yahoo! Messenger - Talk while you surf! It's FREE.
http://im.yahoo.com/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.050 / U:13.820 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site