lkml.org 
[lkml]   [2000]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: ide-scsi problems with plextor IDE drive
Date
I'm having the same exact problem with a Plextor PX-8432T CD-RW drive that 
another person reported back in March (see copy of message by person
identified as "c o r e" below):

Vendor: PLEXTOR Model: CD-R PX-W8432T Rev: 1.07
Type: CD-ROM ANSI SCSI revision: 02

This is an IDE CD-RW drive on /dev/hdc, configured as a SCSI using ide-scsi
emulation. It shows up on my system as /dev/sr0 and /dev/scd0 (I don't know
what the difference is between the two device files, they seem to function
the same).

I cannot mount it! However, somehow (I have no idea how) I did manage to get
it to mount once but after rebooting it would not mount again. Even though I
can't mount it, I can write audio cds with it (and likely data cds too but I
have not tried that yet). When the drive is configured as an IDE drive on
/dev/hdc, I can mount it without any problem as long as I give mount -t
iso9660. Without the -t iso9660 it fails to mount. Its very strange that I
can write cds and play cd music off the drive, but if I try to mount it, it
fails just like "c o r e" experienced below. Is there any fix for this yet?
I'm using Linux kernel 2.2.16. Any help greatly appreciated.


----------------------------------------------------------------------
On Tue Mar 21 2000, 20:33:58 EST, c o r e (core@axley.net) wrote:

I've been having some intermittent problems with a brand new plextor IDE
CD-RW drive under linux. I haven't had any problems reading or writing to
the drive under winDOS 95, nor have I had problems writing to the drive
using cdrecord, but I've had tons of problems reading from the drive (e.g.
mounting a CD). I'm accessing the drive via ide-scsi emulation.

I'm running 2.2.14 and have tried the latest IDE patch (ide20000124) to
see if that would help, but I still have problems.

Here's what happens when I try to mount a CD:

[root@manteador ~]$ mount -t iso9660 -o ro /dev/scd0 /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems
[root@manteador ~]$

Relevant errors from 'dmesg' caused by the mount attempt:

scsi0 : SCSI host adapter emulation for IDE ATAPI devices
scsi : 1 host.
Vendor: PLEXTOR Model: CD-R PX-W8432T Rev: 1.05
Type: CD-ROM ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
Uniform CDROM driver Revision: 2.56
VFS: Disk change detected on device sr(11,0)
ide-scsi: The scsi wants to send us more data than expected - discarding
data
ide-scsi: The scsi wants to send us more data than expected - discarding
data
ide-scsi: The scsi wants to send us more data than expected - discarding
data
ide-scsi: The scsi wants to send us more data than expected - discarding
data
<these errors repeat a total of 84 times>
Unable to identify CD-ROM format.

/etc/conf.modules relevant contents:

# kernel 2.2.x ATAPI SCSI emulation
options ide-cd ignore=hdc # if /dev/hdc is your CD-writer
post-install sr_mod /sbin/modprobe ide-scsi # auto probe module
alias scd0 sr_mod # load sr_mod upon access of scd0
alias scsi_hostadaptor ide-scsi # SCSI host adaptor emulation

I need some assistance in determining if this is a hardware problem or a
linux problem so that I can RMA the drive or linux ;-)

If I try to mount the CD using straight ATAPI mode it works just fine
(i.e. /dev/hdc without scsi modules).

Now oddly that I've re-enabled the ide-scsi modules, I can mount cdroms
with no problem. This doesn't always work.

Perhaps I should enable verbose scsi error reporting... I'll wait to hear
back from you fine folks first. Please CC me on replies since I'm not
subscribed. Tx!

-core
-------------------------------------------------------------------

--
-------- Robert B. Easter reaster@comptechnews.com ---------
- CompTechNews Message Board http://www.comptechnews.com/ -
- CompTechServ Tech Services http://www.comptechserv.com/ -
---------- http://www.comptechnews.com/~reaster/ ------------
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.046 / U:5.636 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site