lkml.org 
[lkml]   [2000]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: 2.4.0-test9-pre8, usb, unresolved symbols
Date
Well, let's see.
linux/drivers/Makefile did change for test9-pre8.
That's one possibility.

Are you building USB core support in-kernel or as a
module? (Maybe provide your .config file, or at least
the CONFIG_USB_xxx portion of it.)

Thanks,
~Randy


> From: f5ibh [mailto:f5ibh@db0bm.ampr.org]
>
> Randy wrote :
> > All of the missing symbols are in usb.o (usbcore.o module or
> > usbdrv.o in-kernel). Is usbcore.o loaded or do you have
> > /etc/modules.conf setup to load it automatically?
> > Did you run depmod after 'make modules_install' ?
>
> I've a Debian 2.2 system. With Debian, I use the "make-kpkg"
> command to build
> the kernel in a Debian package. I ALWAYS use the same process
> to compile
> kernel. Then, I install the new kernel with dpkg as any .deb
> package ... I think
> I've built 100's of them now. depmod reports the same error :
>
> depmod: *** Unresolved symbols in
> /lib/modules/2.4.0-test9/kernel/drivers/usb/hid.o
> depmod: *** Unresolved symbols in
> /lib/modules/2.4.0-test9/kernel/drivers/usb/usb-uhci.o
>
> I use the following in my modules.conf to load automatically
> all the usb related
> stuff when starting 'gpm'. This works with the previous
> test9-prex patches.
>
> # USB mouse
> #----------
> alias char-major-13 mousedev
>
> post-install input modprobe -k hid
> post-install hid modprobe -k usb-uhci
>
> ---

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.034 / U:4.200 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site