lkml.org 
[lkml]   [2000]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4 switches eth0 and eth1 from 2.2
On Tue, Oct 17, 2000 at 08:51:08PM -0400, The Shadow's Hand wrote:
> I've got an Asus P2B-L mobo, which has an integrated eepro100, and an
> DEC Tulip PCI card. I've been running 2.2.16. To use a new ATA/100 card
> I tried 2.4-test10-pre3.
>
> All worked well, indeed very well, except 2.4 switched eth0 and eth1
> from 2.2.x. That is, the Tulip became eth0, rather than eth1 and the
> eepro100 became eth1.
>
> It took me a looong time to figure out the problem. I spent hours
> figuring I had driver trouble. Once seen, easily fixed. But even then,
> it's a pain to boot 2.2.x.
>
> Now I find that ether= won't work for PCI cards ( the Ethernet HOWTO
> needs to be corrected )!!
>
> This is an odd sort of bug ( feature? ) that will drive users of
> multi-nic machines nuts when 2.4 is rolled out. Hopefully it's only for
> my sort of setup.

There are lots of ways how the network interface name can change when you
change kernel configuration (especially between hand loaded modules and
various kernels or when you switch the hd between different boxes with
multiple NICs)

You can always use nameif (ftp.firstfloor.org:/pub/ak/smallsrc/nameif.c)
to avoid such nasty surprises. It is a small tool I wrote some months ago
because I was often plagued by this problem. You give it a file with MAC
addresses and device names, and it renames the network interfaces for you
This needs to be done before they're UP.

You can even use it for logical naming, e.g. myhomenet0

-Andi


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.037 / U:5.812 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site