lkml.org 
[lkml]   [2000]   [Oct]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ide-scsi works now "used to be On ide-scsi recorder failure
I think my confusion came from the fact that i didn't need to reference a
specific device before the kernel upgrade. As for telling it to use
/dev/sg1 or sg0 ... I cant really tell anymore, i'm no longer using that
kernel. It probably was an incorrect usage of cdrecord, so i'm sorry for
the posts here, or it could have been something stupid like not compiling
in scsi generic support (which i'd like to doubt but can't tell now), oh
well, everything works now ...i'm going to test out this atapi-direct write
support if i figure out how to convince cdrecord to use it.




On Sun, 15 Oct 2000 04:51:30 Dax Kelson wrote:

>
> The error you were getting is the error I get on my system when I
> incorrectly try to access the SCSI cdrom device instead of of the SCSI
> generic.
>
> See:
>
> [root@thud linux]# cdrecord dev=/dev/sr1 -inq
> Cdrecord 1.9 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jrg Schilling
> scsidev: '/dev/sr1'
> devname: '/dev/sr1'
> scsibus: -2 target: -2 lun: -2
> cdrecord: No such file or directory. Cannot open SCSI driver.
> cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are
> root.
> [root@thud linux]#
>
> However, when I correctly reference the SCSI generic device, it works:
>
> [root@thud linux]# cdrecord dev=/dev/sg1 -inq
> Cdrecord 1.9 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jrg Schilling
> scsidev: '/dev/sg1'
> devname: '/dev/sg1'
> scsibus: -2 target: -2 lun: -2
> Linux sg driver version: 3.1.17
> Using libscg version 'schily-0.1'
> Device type : Removable CD-ROM
> Version : 2
> Response Format: 2
> Capabilities : SYNC
> Vendor_info : 'YAMAHA '
> Identifikation : 'CRW4416S '
> Revision : '1.0j'
> Device seems to be: Generic mmc CD-RW.
> [root@thud linux]#
>
> In short, I don't think there was a problem, simply incorrect usage of
> cdrecord.
>
> Dax
>
>
>


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.036 / U:9.388 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site