lkml.org 
[lkml]   [2000]   [Oct]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.0-test8 locks up Aladdin V IDE
Hi,

I'm running 2.4.0-test9 on an Aladdin V based mother board. The IDE
interface locks up (i.e. reads/writes etc fail, drives cannot be
detected when booting) and only works again after power cycling. Same
problem occured with 2.4.0-test5 and up. The problem does not occur with
2.2.x kernels (2.2.14 and 2.2.17 tested) with the 1.0 beta 3 driver.

The primary interface has two UDMA33 drives (both of which are
automatically put into UDMA33 mode). The secondary interface has a CD-ROM
drive and a Zip disk but neither are used.

Unfortunatly I have been unable to determine what particular circumstaces
cause the problem as it occurs infrequently (maybe after a few
hours). This first signs are the following messages

hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
hda: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
hda: status timeout: status=0xd0 { Busy }
hda: DMA disabled
hdb: DMA disabled
hda: drive not ready for command
ide0: reset timed-out, status=0x80
hda: status timeout: status=0x80 { Busy }
...and so on...

The problem appears t only occur if I have not previously booted Windows
98.

lspci reports the IDE interface as
Acer Labs M5229 IDE interface (revision c1)

I'm not subscribed to this list please CC any replies.

David Vrabel

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:41    [W:0.023 / U:22.104 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site