lkml.org 
[lkml]   [2000]   [Oct]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Updated 2.4 TODO List - more on PCI resources...
Keywords: cardbus, dell, xircom, pci, resources

In short:
Xircom Realport cardbus cards still do not work under Linux in (my) Dell
Latitude CPi laptop. A problem indication shows up even before loading
the xircom driver. This is not the Latitude docking-station problem,
which has been
noted by others. AFAICT.

Tested with:
2.2.18pre15 + pcmcia-cs 3.1.21
2.4.0-test9/10p1
2.4.0-test9 + pcmcia-cs 3.1.21
quite a few other combinations, including older versions of 2.2 and
2.4-test*
kernels and pcmcia-cs.

I have tried every combination of "rom,bios,direct" as options to the
"pci="
kernel boot-option, 3 different BIOS versions, with and without the
docking
(which has never caused me any grief, mind you), with cardbus support
compiled-in and as modules, and quite a few other tricks and stupidities.
No
go.

As soon as I insert the card (or if the card was inserted prior to boot,
during
boot-time), I get:

cs: cb_alloc(bus 6): vendor 0x115d, device 0x0003
PCI: Failed to allocate resource 1 for PCI device 115d:0003
PCI: Failed to allocate resource 2 for PCI device 115d:0003
PCI: Failed to allocate resource 6 for PCI device 115d:0003
PCI: Enabling device 06:00.0 (0000 -> 0003)
PCI: Failed to allocate resource 1 for PCI device 115d:0103
PCI: Failed to allocate resource 2 for PCI device 115d:0103
PCI: Failed to allocate resource 6 for PCI device 115d:0103
PCI: Enabling device 06:00.1 (0000 -> 0003)

(-test9)

or, in the case of 2.2.18pre15+pcmcia-cs 3.1.21:

Oct 8 20:58:56 dagblap pcmcia: Starting PCMCIA services:
Oct 8 20:58:56 dagblap pcmcia: modules
Oct 8 20:58:57 dagblap kernel: Linux PCMCIA Card Services 3.1.21
Oct 8 20:58:57 dagblap kernel: kernel build: 2.2.18pre15 #1 Sun Oct 8
20:31:01 CEST 2000
Oct 8 20:58:57 dagblap kernel: options: [pci] [cardbus] [apm] [pnp]
Oct 8 20:58:57 dagblap kernel: PCI routing table version 1.0 at 0xfbda0
Oct 8 20:58:57 dagblap kernel: 00:03.0 -> irq 11
Oct 8 20:58:57 dagblap kernel: 00:03.1 -> irq 11
Oct 8 20:58:57 dagblap kernel: PnP: PNP BIOS installation structure at
0xc00fe2d0
Oct 8 20:58:57 dagblap kernel: PnP: PNP BIOS version 1.0, entry at
f0000:e2f4, dseg at 40
Oct 8 20:58:57 dagblap kernel: Intel PCIC probe:
Oct 8 20:58:57 dagblap kernel: TI 1225 rev 01 PCI-to-CardBus at slot
00:03, mem 0x68000000
Oct 8 20:58:57 dagblap kernel: host opts [0]: [ring] [serial pci &
irq]
[pci irq 11] [lat 32/32] [bus 32/34]
Oct 8 20:58:57 dagblap kernel: host opts [1]: [ring] [serial pci &
irq]
[pci irq 11] [lat 32/32] [bus 35/37]
Oct 8 20:58:57 dagblap kernel: ISA irqs (scanned) = 3,7,9 PCI status
changes
Oct 8 20:58:57 dagblap pcmcia: cardmgr.
Oct 8 20:58:57 dagblap rc: Starting pcmcia succeeded
Oct 8 20:58:57 dagblap cardmgr[481]: starting, version is 3.1.21
Oct 8 20:58:57 dagblap kernel: cs: cb_alloc(bus 35): vendor 0x115d,
device
0x0003
Oct 8 20:58:57 dagblap cardmgr[481]: watching 2 sockets
Oct 8 20:58:57 dagblap kernel: cs: IO port probe 0x1000-0x17ff: clean.
Oct 8 20:58:57 dagblap kernel: cs: IO port probe 0x0100-0x04ff: clean.
Oct 8 20:58:57 dagblap kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Oct 8 20:58:57 dagblap cardmgr[481]: initializing socket 1
Oct 8 20:58:57 dagblap kernel: cs: no valid ROM images found!
Oct 8 20:58:57 dagblap cardmgr[481]: unsupported card in socket 1
Oct 8 20:58:57 dagblap cardmgr[481]: no product info available
Oct 8 20:58:57 dagblap cardmgr[481]: PCI id: 0x115d, 0x0003


The hardware is functional. (Tested on NT4.)
lspci -v says:

06:00.0 Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
Subsystem: Xircom Cardbus Ethernet 10/100
Flags: medium devsel, IRQ 11
I/O ports at 1800 [size=128]
[virtual] Memory at 11000000 (32-bit, non-prefetchable) [size=4M]
[virtual] Memory at 11000000 (32-bit, non-prefetchable) [size=4M]
Expansion ROM at 11000000 [disabled] [size=4M]
Capabilities: [dc] Power Management version 1

06:00.1 VGA compatible controller: Xircom Cardbus Ethernet + 56k Modem
(rev
03) (prog-if 02)
Subsystem: Xircom CBEM56G-100 Ethernet + 56k Modem
Flags: medium devsel, IRQ 11
I/O ports at 1880 [size=8]
[virtual] Memory at 11000000 (32-bit, non-prefetchable) [size=4M]
[virtual] Memory at 11000000 (32-bit, non-prefetchable) [size=4M]
Expansion ROM at 11000000 [disabled] [size=4M]
Capabilities: [dc] Power Management version 1

This line:
"Expansion ROM at 11000000 [disabled] [size=4M]"

doesn't look very positive. Can the PCI resource allocation code handle a
4M
ROM image? (To the extent which the PCI code cares...?) I do know other
users with the exact same type of Xircom card, so this is quite possible
some quirk with this particular laptop model. (CPiA 366XT)

Any takers?
Let me know what debug-switches and knobs I can turn on, and what
information
I can provide.


Regards,

Dag B
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.056 / U:0.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site