lkml.org 
[lkml]   [2000]   [Oct]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectBIG problem with BusLogic SCSI and/or something else

I tried to add a new Hard disk. It's s Seagate ST39102LW 8.1 Gb.
In the BIOS setup of the BusLogic adapter, I was able to format
and verify the disk with no problems whatsoever.

fdisk seemed to work okay. I made partitions.
mke2fs would fail (hang the system) while writing inodes.
The BusLogic driver would complain about "Aborting SCSI host 0 channel 0,
pid 84446".

This can't be a pid --anyway.

I downloaded what preports to be the latest e2fsprogs-1.19. Still the
same problem.

Script started on Wed Oct 11 16:43:04 2000
# fsck --version
Parallelizing fsck version 1.19 (13-Jul-2000)
# mke2fs --version
mke2fs 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09
mke2fs: invalid option -- -
# fdisk --version
fdisk: invalid option -- -
# fdisk -v
fdisk v2.9g
# fdisk /dev/sdd

The number of cylinders for this disk is set to 1106.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/sdd: 255 heads, 63 sectors, 1106 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/sdd1 * 1 804 6458098+ 83 Linux native
/dev/sdd2 805 821 136552+ 82 Linux swap
/dev/sdd3 822 1106 2289262+ 83 Linux native

Command (m for help): q
# fsck /dev/sdd1
Parallelizing fsck version 1.19 (13-Jul-2000)
e2fsck 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09
/dev/sdd1 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Entry 'bin' in / (2) has deleted/unused inode 32321. Clear<y>? yes

Entry 'boot' in / (2) has deleted/unused inode 64641. Clear<y>? yes

Eventually everything gets deleted (a whole root file-system). This was
a mirror of my usual root file-system. It blew up when I was trying
to tar from one to another.

# mount /dev/sdd1 /mnt

# df
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/sdc1 1973472 1679755 191706 90% /
/dev/sdc3 2082225 1260696 713894 64% /home/users
/dev/sda1 1048272 274256 774016 26% /dos/drive_C
/dev/sda5 1046224 163104 883120 16% /dos/drive_D
/dev/sdb1 2020332 1666911 249001 87% /alt
/dev/sdd1 6356624 20 6033700 0% /mnt
# umount /mnt
# exit
exit
Script done on Wed Oct 11 16:46:41 2000


When the BusLogic driver was going through its hour-long fits of
resetting the bus, it rewrote the NVRAM configuration in the controller
so that the disk-drives were not at the same logical addresses when
I attempted to reboot. It turned on SECAM (whatever that is), and
scattered the addresses of the drives all over the place so the boot
drive was not found.

I thought that SCSI controllers were required to use the hardware address
of the drives, however there is something strange. The boot drive had
been moved from 0 to 15.

It was only after I found this obscure configuration junk that the
drives were able to be found where the physical bits put them.


Cheers,
Dick Johnson

Penguin : Linux version 2.2.17 on an i686 machine (801.18 BogoMips).

"Memory is like gasoline. You use it up when you are running. Of
course you get it all back when you reboot..."; Actual explanation
obtained from the Micro$oft help desk.


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.065 / U:15.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site