lkml.org 
[lkml]   [2000]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: tmscsim update for Linux 2.2.18pre15?
On Tue, Oct 10, 2000 at 11:52:33AM +0200, Matthias Andree wrote:
> On Mon, 02 Oct 2000, Alan Cox announced:
> > 2.2.18pre15
>
> I'd like to know if there are any issues with the current dc390-2.0e or
> 2.0e3 drivers that prevent its inclusion/that prevent Kurt from
> submitting it for inclusion. As per the web page, 2.0e was supposed to
> be sent to Linux for 2.4, so it should not have been too bad ;)

Right. 2.0e was supposed to be sent off, but unfortunately, some new error
reports came up which I wanted to address. Then you run out of time because
you have other projects and the thing gets lost.

Actually, 2.0e3 did include one rather important fix which solved the
trouble: Some devices get upset, when the driver tries to negotiate sync
(or wide) connections, but the device actually does not support it.
So, the driver now waits for the first INQUIRY result and parses the
relevant fields to determine, whether sync should be tried.

As far as I can conclude from the reports I got since the 2.0e3 release (two
weeks ago), it solves the remaining issues.

I'll happily sent a patch against 2.4.0t9 and/or 2.2.18p15 to Linus/Alan to
get an updated version included in the mainstream kernel.

Regards,
--
Kurt Garloff <garloff@suse.de> Eindhoven, NL
GPG key: See mail header, key servers Linux kernel development
SuSE GmbH, Nuernberg, FRG SCSI, Security
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.073 / U:4.992 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site