lkml.org 
[lkml]   [2000]   [Oct]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: What is up with Redhat 7.0?
On Sat, Sep 30, 2000 at 09:36:56PM +0200, Marc Lehmann wrote:
> > Various people I associate with being senior in both glibc and gcc (people
> > like Ulrich Drepper and Jeff Law) were involved in the compiler and glibc
>
> they were involved, but I have reason to doubt that they actually agreed.

You would be wrong then. Management asked what version of gcc would
be best to support, we answered, they followed our recomendation.

If you want to blame someone in Red Hat for making the decision to
ship a gcc snapshot, then you might as well blame me.

The reasons are the following:

(1) 2.95 is the least stable release that we (the fsf gcc team) have
shipped in a long time. It does ok on x86, but is pathetic on the
other platforms that Red Hat cares about -- especially Alpha.

The late July snapshot we shipped is most definitely more stable,
largely I think due to Geoff's automated regression tester bitching
at people when they break the tree.

(2) C++ in 2.95 is already ABI incompatible with egcs 1.1 and gcc 3.0,
so clearly (to my mind anyway) it didn't matter whether we
shipped 2.95 or a snapshot, we would still be incompatible with
Red Hat 6 and Red Hat 8.

(3) While the C++ ABI for 3.0 is not complete, the API is. That is,
the snapshot we chose will be compatible with 3.0 at the source
level. With the exception of "export" I understand from Jason
that we are now very close to standards conformance.

(4) We could either spend our QA time reviving the dead 2.95 branch,
or we could spend that QA effort on mainline, helping get 3.0
stable.

Someone on this thread complained that the RPM that we shipped
is highly patched. Bar two (the subreg_byte patches), all of
those patches are in current cvs. Since at some point procedure
would not allow us to take a new snapshot, those 85 patches are
a visible side-effect of the QA work that was done.

Frankly, I didn't even consider C++ ABI compatibility with other
Linux vendors, since I think that's a losing proposition until
everyone is using gcc3. We were _already_ incompatible, since
there are a mix of egcs and gcc versions involved.

Flame away.


r~
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.166 / U:9.368 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site