lkml.org 
[lkml]   [2000]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Data corruption reading IDE CD-ROM in 2.2.x
    On Sun, Jan 09 2000, Khimenko Victor wrote:
    > My CD-ROM (SONY CDU4011) will not corrupt anything when used with DMA enabled.
    > It'll just froze the whole system. As it does this in both all versions of
    > Linux I've tried and in Windows98 I suspect hardware problem ...
    > Since I am used few different hard disks with DMA for more the year here I
    > think it's CD-ROM problem and not MB problem.

    I have a similar Sony that works just fine with DMA here.

    > P.S. BTW is it possible to turn off DMA usage when there are no CD in drive ?
    > hdparm -d 0 giving 'No medium found' and when I forget to disable DMA before
    > first try to mount CD I'm getting total system freeze :-(( Really annoying ...

    hdparm should open O_NONBLOCK for CD-ROM, that is why it fails. Andre
    carried a hdparm once and it had my patch for that included.

    --
    * Jens Axboe <axboe@image.dk>
    * Linux CD-ROM Maintainer
    * http://www.kernel.dk

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:55    [W:0.058 / U:0.276 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site