lkml.org 
[lkml]   [2000]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    Subjectdevel kernel ppp bug
    I recently compiled 2.3.36 to find this error when the pppd was called: 

    (root)[~]#ppp-go
    (root)[~]#Serial connection established.
    ioctl(TIOCSETD): Invalid argument(22)

    Considering I was using slackware's ppp-go script, I used minicom, then
    tried to call the pppd by hand, and still received the same error. I also, updated from pppd 2.3.10 to pppd 2.3.11 and did a make kernel, then recompiled the kernel and received the same error. I understand that ioctl is a C function, and this is most likely a pppd error. Strange thing is,that it works with all other kernels, including 2.3.34 and 2.3.35.

    Happy Coding!

    -W.D. Ledbetter
    --


    Get your free email from http://www.windrivers.net

    Also visit:
    http://www.windrivers.com
    http://www.winreviews.com


    powered by OutBlaze

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:55    [W:0.029 / U:29.256 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site