[lkml]   [2000]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [patch-2.3.40-pre6] kzalloc() (ala kmem_zalloc() of SVR4)
On Sat, Jan 22, 2000 at 02:46:37AM +0000, Alan Cox wrote:
> > Wrong again, it makes the code less readable because kzalloc() is a
> > non standard function name. This looks more to me like a patch just
> > for the sake of the patch.
> Since when has "kmalloc" been a standard name anyway ?

Why do we have printk anyway? It serves the same purpose as printf and
is even tagged as `taking arguments like printf' for gcc's type-checking
benefit. It makes it harder to take large chunks of code and move it
to userspace for testing (ok, i can #define printk printf, but still).
Just Hysterical Raisins?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:56    [W:0.078 / U:1.424 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site