lkml.org 
[lkml]   [2000]   [Jan]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Patch] Cleanup struct gendisk registration, 2.3.40-pre1
On Sat, 15 Jan 2000, Alexander Viro wrote:

> hd vs. ide one? IIRC, there were some problems with it (testing order?)
> It should be solvable by telling ide driver to STFU and don't touch the
> first interface if hd is there. Making hd a module is not hard, so...
> BTW, did somebody actually try to use current ide.c with ST-506 controllers?

Not a major issue if dealing with IDE-PCI on a add-on card; however,
both hd.c and onboard-legacy ide-pci is an issue that will be worth about
4 asprin........Some chipsets allow for IO redirect/assignment to Tertiary
and Quaternary io address and interrupts, but this is only on data sheets.
I have never tried it nor understood the sequence of the brute-force
attack required upon the HOST-bridge and ISA-bridge to switch the IO base
addresses and then correct the PIRQ routing table.
Also this happens after the PCI subsystem has completed its task of the
setup.........thus IDE would have to stop and redirect the BOOT process to
call "pci_init()" and begin again........
NO WAY in God's green earth am I going to suffer the WRATH of that
proposal, the screw up that will happen, or hanging onto init-level global
variables to prevent a deadlock init-loop.........
If you want to run/boot off a "ST-506 controller" ........ any and all
ide-hwifs that default to ide0=0x1f0,0x3f6,14 or ide1=0x170,0x3f6,15
have to be clobbered and never be allowed to init.........

Gadi,

If you have a minute, chime in please...

> There is another interesting issue with modules: we have dependencies in
> IDE family and for modules they guarantee some ordering. AFAICS it is
> different from the sequence of initializations in case of built-in stuff.
> Something is very bogus with ide-scsi and it's not the current patch -
> the problem is that sometimes it fails to read partition table / mount the
> stuff. And it's not a timeout issue - at least not directly. It complains
> about the bogus requests in the subdriver's queue. Looks like it's doing
> so since '97-'98...

Alex,

You are correct........regardless of the point at which the first
partition is set, it issues the same error. However, in native mode
"ide-floppy" it does correctly handle the partition location.
Since I am still light on the ATAPI and it is a SCSI emmulation,
what happens if you push the partition order around on a native SCSI-ZIP?

Note that my ide-zipdrive has a work-around,

/*
* We used to check revisions here. At this point however
* I'm giving up. Just assume they are all broken, its easier.
*
* The actual reason for the workarounds was likely
* a driver bug after all rather than a firmware bug,
* and the workaround below used to hide it. It should
* be fixed as of version 1.9, but to be on the safe side
* we'll leave the limitation below for the 2.2.x tree.
*/
if (strcmp(drive->id->model, "IOMEGA ZIP 100 ATAPI") == 0)
{
for (i = 0; i < 1 << PARTN_BITS; i++)
max_sectors[major][minor + i] = 64;
}
I have not tried this but there is a SCSI blacklist of features, correct?
This must be flagged there also, many folks like the security lock
features that the SCSI ZIP supports with ATAPI commands that the
IDE-floppy driver does not attempt yet.


Andre Hedrick
The Linux IDE guy



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:55    [from the cache]
©2003-2011 Jasper Spaans