[lkml]   [2000]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Big Swap...
On Fri, 14 Jan 2000, Guest section DW wrote:
> In that case you must be very precise, tell exactly which commands
> you gave, and which replies you got, and what the versions of the
> programs are.
> Things just work fine for everybody including me, so most
> likely it is your fault. But of course there may be a bug
> somewhere.
> Andries

It probably is my fault, and my guess is something else in userland needs
to be upgraded since this has been running Linux for a long time and started
out as a 2.0.x machine. It's on a Sun 4/670MP; the machine has been very
stable except that INN's running it out of swap at times, so I'm trying to fix

But as a consequence of being installed so early, include files, etc, are
not all current. I think it was originally installed from RedHat 4.0, at which
time the 4/670MP wasn't officially supported, and actually prior to the 2.2.x
kernels we had to run with CPU's because it would hang trying to detect the
second module.

The trick is figuring out WHAT...

The existing swap partitions work; and if I dd them to the new partition,
save for size, it works.

But any swap partition I try to make with the new swapon fails.

The partition I'm trying to make is /dev/hdb1 and I've tried large
partitions, and small, same error no matter what. I've tried old version and

mkswap -f -v0 /dev/sdb1
mkswap -f -v1 /dev/sdb1

And without the '-f' and without the -vX allowing it to default.

Then I try to do:

swapon /dev/sdb1 it fails, for example:

# /sbin/mkswap -f -v1 /dev/sdb1
Assuming pages of size 8192
Setting up swapspace version 1, size = 524189696 bytes
# /sbin/swapon /dev/sdb1
swapon: /dev/sdb1: Invalid argument
# uname -a
Linux eskinews 2.2.14 #2 SMP Wed Jan 5 12:13:34 PST 2000 sparc unknown

I don't know how to get the version of mkswap, but it was the version that
came with: util-linux-2.10d, which was the newest version I could find on

# /sbin/swapon -V
swapon: mount-2.10d

Also, I get the following error logged:

Jan 14 12:44:31 eskinews kernel: Unable to find swap-space signature

I got this whether I try the old or the new version, i.e., -v0 or -v1.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:55    [W:0.065 / U:0.448 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site