lkml.org 
[lkml]   [1999]   [Sep]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Strange 2.2.X hard hang....

    Generic reply to the people that replied to me,

    I'll definitely try both (probably simultaneously) to avoid the OOM headaches...
    the HEAP_SIZE thing sounds right, I saw that when I diffed some of the
    arch/i386/boot/ code between 2.2.12/2.3.18, I just didn't think hard enough I guess
    :)

    WRT memory timings and hardware stuff... I tried simultaneously detuning everything
    I could find to tune in the BIOS (SDRAM timings, SDRAM Wait State, PCI "host fast
    bus data ready", some other PCI stuff, etc...) to no avail already... I also tried
    booting with mem=XXXX set at various smaller sizes down as far as 4M and still got
    the hangs.

    So that means to me if its a memory error, its a really bad one that doesn't go
    away with slower timings, and is in the first 4M of memory..... since 2.3.18 and
    BeOS 4.5.2 run OK on this machine, and Win98 runs as ok as it runs anywhere else on
    this machine, I'm guessing there's not a serious physical memory problem in the
    first 4MB....

    Anyways..... so to summarize... I'm going to apply the OOM fix and look at IKD for
    finding the main problem... I'll get back in a few days If I can find something
    more definite.

    Thanks,

    Brandon

    Matthias Hanisch wrote:

    > On Tue, 21 Sep 1999, Alan Cox wrote:
    >
    > > > 1) LILO loads kernel, kernel starts decompressing, and quickly hangs
    > ......

    >
    > > There is a patch for this (it uses gzip -3 not gzip -9 to avoid running
    > > out of boot workspace). That will make the rest of life easier.
    >
    > I think the right fix is to increase the HEAP_SIZE to a sane value (which
    > got into 2.3.15 BTW).
    >
    >


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:54    [W:0.020 / U:0.700 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site