lkml.org 
[lkml]   [1999]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectPlease help! I can't seem to get SYSRQ to work. I've read the docs and compiled the kernel with Kernel Debugging turned on.

Hi,

Sorry if this at all off-topic.

I am getting hard lockups while downloading files over a PCMCIA modem
connection.
As far as I can tell, all I/O is frozen (mouse pointer stops moving,
CTRL-ALT-DEL
doesn't cause my system to shut down, etc.). I am forced to power cycle
the machine.

I have read sysrq.txt and followed the instructions for checking
the SYSRQ key mapping. showkey gives output like this for "ALT-SYSRQ-R"
and "F12-R":

ALT-SYSRQ-R

0x38 0x54 0x13
0xd4 0x93 0xb8

F12-R

0x13 0x58
0x93 0xd8
0x58 0x13
0xd8 0x93

The annoying thing is that I have been unable to verify that
the SYSRQ stuff is working. I have tried getting memory info
to be dumped to the console, with no success. After ALT-SYSRQ-M
failed, I tried remapping SYSRQ to F12 in keyboard.h. That didn't
work either.

Please, if you have any idea what I'm doing wrong, please let me
know. I am really frustrated that I have been unable to collect
ANY information about what is causing my kernel to lock up.

Thanks a million!

Miles

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:53    [W:0.025 / U:4.300 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site