[lkml]   [1999]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] final support for MODULE_PARAM as kernel commandline
I think this is generally a GREAT thing, and something I've wanted for
a long time, but never got around to doing.

However... I think we can't just grab the module parameter name and
use that as a boot parameter name: each module currently has its own
"namespace" for parameters, and you're going to get tons of conflicts
this way. For instance, there are tons of things like:

MODULE_PARM(io, "i");
MODULE_PARM(debug, "i");


There are two options for dealing with this: either invent a standard
naming convention (i.e., "io" becomes "3c501_io") and live with that
for both module parameters and boot parameters, or, have a way of
specifying a prefix just for boot parameters, like:

__setup(MODULE_PREFIX #var "=", modparm##var##_setup);

I tend to prefer the prefix thing because I think it would cause less
disruption. Module parameters could still use the short form everyone
expects. Driver updates would consist of just adding a macro for the

It would also be nice to parse more of the argument classes, including
the array-of-int things. But that can be added later.

-- Dave Hinds

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:53    [W:0.067 / U:3.720 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site