lkml.org 
[lkml]   [1999]   [May]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.2.9 probs (ide hd, quota, 128MB (+sort))
Hi. I have Abit BX6 rev.2.0 ver.HJ, Mendocino 83.333*5.5 MHz,
egcs-1.1.2, binutils-2.9.1.0.23, RH50+updates (a lot)...

problem #1: my IBM DTTA 351350 IDE-disk isn't detected in a sane way.

[root@safari /var/log]# hdparm -i /dev/hdd

/dev/hdd:

Model={sM-wwws=37s3u2p, FwRev=T5Gosw3q, SerialNo=WWrww3q663w
Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR<=5Mbs
DTR>5Mbs DTR>10Mbs dStbOff TrkOff }
RawCHS=40768/16/63, TrkSize=0, SectSize=0, ECCbytes=34
BuffType=12371(?), BuffSize=464kB, MaxMultSect=16, MultSect=16
DblWordIO=no, maxPIO=2(fast), DMA=yes, maxDMA=2(fast)
CurCHS=2557/255/63, CurSects=872152947, LBA=yes
LBA CHS=13572/1020/63 Remapping, LBA=yes, LBAsects=833818160
tDMA={min:120,rec:120}, DMA modes: sword0 sword1 sword2 *mword0 *mword1
*mword2 mword?
IORDY=on/off, tPIO={min:240,w/IORDY:120}, PIO modes: mode3 mode4
UDMA modes: mode0 mode1 mode2

hdparm values look quite rand()'ish on every boot.

for some reason, identification isn't always the same:

kernel: hdd: [rM-wwwq=37s353p, ATA DISK drive
kernel: hdd: [rM-wwwq=37s353p, 407137MB w/464kB Cache,
CHS=40768/16/63, (U)DMA
kernel: hdd: [PTBL] [2557/255/63] hdd1 < hdd5 hdd6 >
<...>
kernel: hdd: {sM-wwwq=37s3u3p, ATA DISK drive
kernel: hdd: {sM-wwwq=37s3u3p, 407137MB w/464kB Cache,
CHS=40768/16/63, (U)DMA
kernel: hdd: [PTBL] [2557/255/63] hdd1 < hdd5 hdd6 >
<...>
kernel: hdd: _~M-t~TA-35135v>, ATA DISK drive
kernel: hdd: _~M-t~TA-35135v>, 963553MB w/464kB Cache,
CHS=57152/16/63, (U)DMA
kernel: hdd: [PTBL] [3586/255/63] hdd1 < hdd5 hdd6 >
<...>
kernel: hdd: _~M-t~TA-35135v>, ATA DISK drive
kernel: hdd: _~M-t~TA-35135v>, 930785MB w/464kB Cache,
CHS=56112/16/63, (U)DMA
kernel: hdd: [PTBL] [3520/255/63] hdd1 < hdd5 hdd6 >
<...>


*****


problem #2: linux versions 2.2.[1-9] don't understand that I
have 128 MB memory. BIOS always detects+tests 128 MB ok.
win95 uses 128 MB happily(!).
BIOS settings, mem=127M etc. didn't make any difference.

kernel: Memory: 127780k/131008k available
(1100k kernel code, 408k reserved, 1632k data, 88k init)
kernel: Memory: 63904k/66496k available
(1100k kernel code, 408k reserved, 996k data, 88k init)

/proc/mtrr seems OK on every boot, however:
reg00: base=0x00000000 ( 0MB), size= 128MB: write-back, count=1
reg01: base=0xe4000000 (3648MB), size= 4MB: write-combining, count=1

But... I solved this. I run one protected mode proggy in MSDOS before
loadlin loads linux. It just allocates 65804 kB and clears it.
If I don't run the proggy, linux uses 66496 kB always.


*****


problem #3: quota is screwed up in 2.2.9
if I use sync(1), sync doesn't succeed and stays in copy_strings()
forever and I can't access the quota-enabled-partition.
if quota is disabled for the partition, sync works OK ;).


*****


problem #4: magic sysrq+p doesn't find the symbol name for EIP...

[OFFTOPIC]

ARGH! Not kernel problem... but since I figured out the cause...:

[root@safari /boot]# time env LANG=fi_FI.ISO-8859-1 \
sort System.map-2.2.9 | head -1
c01aad58 T ftape_start_tape
Broken pipe

real 0m0.659s <***
user 0m0.652s
sys 0m0.004s
[root@safari /boot]# time env LANG=SWAHiLi \
sort System.map-2.2.9 | head -1
c0100000 A _text
Broken pipe

real 0m0.051s <***
user 0m0.043s
sys 0m0.008s

very clever locale support in textutils-1.22k... :(
is strcoll() any faster in glibc-2.1 (than in 2.0.7)?

[root@safari /boot]# echo -n 'a' | od -h
0000000 0061
0000001
[root@safari /boot]# echo -n '0' | od -h
0000000 0030
0000001
[root@safari /boot]# env LANG=SWAHiLi echo -n 'a' | od -h
0000000 0061
0000001
...

;-)



BTW, if someone happens to read this: would some widely used
benchmark give better values if the binary is compiled with -static?
Or am I nuts?

#include <stdio.h>
int main() { printf("*"); }

this nice little execve()-benchmark executes 214% faster when
compiled with -static.

# time for i in `perl -e 'print "A "x1000'`; do ./blaa-static; done



--
Safari - sfarin@ratol.fi - PGP key 0x443BD271 - http://surf.to/safari
"One World, One Web, One Program" - Microsoft Promotional Ad
"Ein Volk, Ein Reich, Ein Fuhrer" - Adolf Hitler


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:51    [W:0.023 / U:14.684 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site