lkml.org 
[lkml]   [1999]   [May]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[SOLVED] Re: ICMP Weirdness (old bug resurfaced?)
On Sat, 1 May 1999, David Miller wrote:

> Looks like it's trying to query a yp server, you may need to fixup
> your /etc/nsswitch.conf

Your comments about yp servers set off an alarm bell in my head, and I
have a sad and salutary story to tell. A few weeks ago, some fuckwit
mailbombed me (I received over 3,000 obscene messages telling me what to
do with my mother!), and it prompted me to install an anti-spam program on
my system. Along the way (I installed that correctly at least as it turns
out), I discovered the identd daemon wasn't working properly because
hosts.deny/hosts.allow weren't configured properly and I did fix this.
However along the way, I also made two mistakes, both these errors
together caused the icmp (and also sunrpc) problems. In my wisdom, I made
the error of thinking dnsdomainname set the machine's domain name (i.e
tahallah.demon.co.uk). As it turns out it is not what I thought it was! At
that point, I made the second mistake, whch was to type in 'domainname'
instead of 'dnsdomainname' (which would have almost certainly told me that
this wasn't what I was trying to do!). As domainname is for yp servers,
this caused both the sunrpc & icmp problems I had experienced. Removing
domainname cured all these problems.

Gaaah. I need to go put my head down the nearest toilet or something. At
least I can laugh now that I've solved this.

Cheers,
Alex
--
"A mind opened by new ideas can never return to its original limits"

http://www.tahallah.demon.co.uk


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:51    [W:0.042 / U:5.452 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site