lkml.org 
[lkml]   [1999]   [Apr]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    Subjectun.h (2.2.5) breaks bind 8.2 compile?
    Seems bind 8.2 compile is choking on sa_family_t in
    /usr/src/linux/include/linux/un.h:

    from un.h kernel 2.2.5:

    #ifndef _LINUX_UN_H
    #define _LINUX_UN_H

    #define UNIX_PATH_MAX 108

    struct sockaddr_un {
    sa_family_t sun_family; /* AF_UNIX */
    char sun_path[UNIX_PATH_MAX]; /* pathname */
    };

    #endif /* _LINUX_UN_H */

    I changed "sa_family_t" to "unsigned short" and the bind compile doesn't
    choke on sa_family_t anymore, odd thing is this compile doesn't
    choke on a Red Hat machine, I run a Slackware 3.6 box. I have tried
    to compile on other Slackware 3.6 kernel 2.2.5 boxes, and I get same
    error.

    Is sa_family_t a glibc thing?


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:51    [W:0.018 / U:156.444 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site