lkml.org 
[lkml]   [1999]   [Apr]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: How to force "make modules_install" to install elsewhere
Date
From
> Nope.  It seems that your 2.0.36 and mine are not the same.  Mine
> is from ftp.kernel.org/....linux-2.0.36.tar.gz

Yes, vanilla 2.0 is missing this feature, as I've just discovered
yesterday. This brings it in sync with 2.2, the prefix is INSTALL_MOD_PATH.
Should be added to the next 2.0 because it is useful and breaks nothing.

--- Makefile~ Wed Apr 28 18:38:17 1999
+++ Makefile Wed Apr 28 18:49:37 1999
@@ -284,7 +284,7 @@

modules_install:
@( \
- MODLIB=/lib/modules/$(VERSION).$(PATCHLEVEL).$(SUBLEVEL); \
+ MODLIB=$(INSTALL_MOD_PATH)/lib/modules/$(VERSION).$(PATCHLEVEL).$(SUBLEVEL); \
cd modules; \
MODULES=""; \
inst_mod() { These="`cat $$1`"; MODULES="$$MODULES $$These"; \
Olaf


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:51    [from the cache]
©2003-2011 Jasper Spaans