lkml.org 
[lkml]   [1999]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: sync problem in 2.2.5
Hi Chris,

Here are some more inputs;

from ps -lwa | grep sync

0 500 10456 751 0 0 1020 324 wait_on_dqu D ? 0:00 sync

where wait_on_dqu = 'c0133151' when using ps -lwan

It does not only takes time, but really Died!

I'v upgraded my fileutils to 4.0 from 3.16 and still the same,
I also reompiled it (synce I'm using glibc2.1 and still the same.

Most often it "freeze" thoe whole gnome interface and keyboard/mouse, only way out is to telnet in and then "shutdown -r -n now", then wait few seconds and then press "reset" or turn off the machine, and sometime "unplug" from the wall (ATX power supply).

Is there any way I can try to trace it so I can give you more info?

Thanks
Andre


On Mon, 19 April 1999, Chris Wedgwood wrote:

>
> On Mon, Apr 19, 1999 at 08:51:14PM +0200, Andre Couture wrote:
>
> > It "hang" my system and sometimes just the window from which I'm
> > running the command "sync".
>
> If you have lots of dirty pages and lots of memory, sync can take
> several seconds and hold up any processes which do IO. This is
> especially noticeable on systems with only a single spindle or a vfs
> made of relatively few physical filesystems, but it also occur at the
> high end as well and will be a problem until be get per device
> queues.
>
>
>
>
> -cw

Andre Couture
PCDOCS/Fulcrum S.A. - Europe

Office: +33(1)46.29.07.40
GSM Europe: +33(6)07.04.35.65
FAX/Voicemail Europe: +33(1) 53.01.29.63
FAX/Voicemail Canada: +1(514) 221-2261


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:51    [W:0.021 / U:4.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site