lkml.org 
[lkml]   [1999]   [Dec]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: hda lost interrupt!
Blanket nuking is the only way I can boot my laptop.  If DMA is enabled in
the kernel, when it boots, it hangs with the lost interrupt message at the
point where it does the partition checking.

It used to do that when I resumed from an APM suspend state. Then the
motherboard overheated from being left turned on and left on the carpet (APM
disabled) and went to depot. After receiving it with a new motherboard, all
my attempts to use DMA on it w/ a current kernel result in lost
interrupt/hang.

The HD itself is a Fujitsu and certainly does DMA ok, it worked on the
previous motherboard so long as APM standby was disabled.

If you'd like the information posted again about the system, I'll be glad to
send you a mail.

-d

On Thu, 30 Dec 1999, Andre Hedrick wrote:

> Date: Thu, 30 Dec 1999 09:23:21 -0800 (PST)
> From: Andre Hedrick <andre@suse.com>
> To: David Ford <david+validemail@killerlabs.com>
> Cc: Vikram <vikram@controlnet.co.in>, linux-kernel@vger.rutgers.edu
> Subject: Re: hda lost interrupt!
>
>
> I have all of that fixed, I hope, but I am shaking down a few other
> issues. I hope to have a solution for 2.3.36.
>
> As for the blanket nuking.........overkill......
>
> There are various combinations of drives and hardware that sometimes do
> not play well togather.........also there are drives that do play with
> other drives period.
>
> Since the is zero data on the device and host in question, I would wait
> for the at before making a blanket judgment call.
>
> On Wed, 29 Dec 1999, David Ford wrote:
>
> > Disable DMA for your harddrive, don't even compile it into the kernel.
> > Something in the recent kernels is busted wrt IDE DMA.
> >
> > -d
> >
> > On Wed, 3 Nov 1999, Vikram wrote:
> >
> > > I am developing a driver for my nic problem is afetr some operations the
> > > system gives "hda lost interrupt" and then I am not able to see any
> > > debugging info in the /var/log/messages after that.. and machine gets hanged
> > > goes on giving messages "hda lost interrupt"...
> > > what can be reason for this?
> > > I am not getting any reply for my previous queries also.
> > > TIA
> > > --VIKRAM
> >
> > --
> >
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majordomo@vger.rutgers.edu
> > Please read the FAQ at http://www.tux.org/lkml/
> >
>
> Andre Hedrick
> The Linux IDE guy
>

--
Open for Y2K - Linux, we never shutdown


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:55    [from the cache]
©2003-2011 Jasper Spaans