lkml.org 
[lkml]   [1999]   [Dec]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectStrange behaviour with token ring (update)
I've been experimenting with the IBM Token-Ring cards the whole day. A faint of hope appeared on the horizon when I read that the io-address of the token ring card was actually identical to the io-address of the ethernet card (0xa20 = 0x220) But after removing the ethernet card the problem still exists.
I took then a second computer (PIII 450) and installed Linux (RH 6.0) in it. I configured the card with the same settings as in the other computer (io=0xa20, irq=9, mem=0xd0000). When I insert the ibmtr (kernel 2.2.13) modules I get the following output:
tr0: ISA P&P Auto 16/4 Adapter found
tr0: using irq 9, PIOaddr a20, 8k shared RAM
tr0: Hardware address : 00:04:AC:75:33:23
tr0: Maximum MTU 16Mbps: 2008, 4Mbps: 2008
The LED at the back of the network card starts blinking slowly (around every second). When I try to set an IP-adress for the tr0 interface ifconfig just hangs and can't be killed (even kill -9 doesn't work)

Back at the old Cyrix 6x86 PR166: I removed the ethernet card, too. Still the same problem. Packet loss is about 30%-50% packet loss. (I have the feeling that it's gotten better, but it's still bad)

I tried a second IBM token ring card just to make sure the card is not broken but got the same results.

I even tried an OC-3137 with the Olicom drivers. But these just lock up the whole machine when I insmod the driver. (only a hard reset works)

I slowly run out of ideas. Please help me!

Desperate
Martin



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:55    [from the cache]
©2003-2011 Jasper Spaans