lkml.org 
[lkml]   [1999]   [Dec]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: insmoding aha152x never returns in 2.3.33
Date
From
Tim Waugh <twaugh@redhat.com> said:
> On Mon, 20 Dec 1999, Giacomo Catenazzi wrote:
> > Why 'mount' with kmod fails loading the imm module without go to an
> > uninterruptible sleep, but insmod do it?

> Well, what is the error? I expect that kmod doesn't know which module to
> load (do you have a scsi_lowlevel alias in modules.conf?).

I have both scsi_lowlevel (is that one really needed?!) and
scsi_hostadapter there. On 2.3.34pre2, i686, egcs-1.1.2,
binutils-2.9.5.0.22 an "mdir z:" hangs:

[vonbrand@sleipnir vonbrand]$ /sbin/lsmod
Module Size Used by
ppa 9532 (initializing)
parport_pc 14324 1 (autoclean)
parport 26784 1 (autoclean) [ppa parport_pc]
sd_mod 10412 (initializing)
scsi_mod 64540 0 (autoclean) [ppa sd_mod]
floppy 45644 0 (autoclean)
slip 7800 0 (autoclean)
via-rhine 9720 1 (autoclean)

[vonbrand@sleipnir vonbrand]$ ps lp 5991
F UID PID PPID PRI NI VSZ RSS WCHAN STAT TTY TIME COMMAND
100 0 5991 1042 0 0 1284 500 wait4 S pts/1 0:00 mdir z:

Even so, kmod does load lp and prints normally.
--
Horst von Brand vonbrand@sleipnir.valparaiso.cl
Casilla 9G, Viña del Mar, Chile +56 32 672616

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:55    [from the cache]
©2003-2011 Jasper Spaans