lkml.org 
[lkml]   [1999]   [Oct]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: PCI patch for 2.3.21
Just wanted to report PCI problems with 2.3.21.  I have tried Martin
Mares patch posted a couple of days ago; it did not help.

Symptoms: Most of my PCI devices are not recognized or properly
configured by 2.3.21 upon boot. I don't get any OOPses or crashes, but
many devices don't work. The system is a Dell Latitude CPi D266XT
Laptop. It works fine under 2.2.13 (up to and including pre16).

Output of lspci under 2.2.13pre16:

00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge
(AGP disabled) (rev 02)
00:02.0 VGA compatible controller: Neomagic Corporation NM2160
[MagicGraph 128XD] (rev 01)
00:03.0 CardBus bridge: Texas Instruments PCI1131 (rev 01)
00:03.1 CardBus bridge: Texas Instruments PCI1131 (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 01)
00:11.0 PCI bridge: Intel Corporation 82380FB (rev 01)
01:05.0 IDE interface: CMD Technology Inc PCI0646 (rev 03)
01:07.0 SCSI storage controller: Adaptec AIC-7860 (rev 03)
01:08.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX
[Boomerang]

Messages in /var/log/messages:

Oct 12 23:34:12 host kernel: PCI: PCI BIOS revision 2.10 entry at
0xfbbee
Oct 12 23:34:12 host kernel: PCI: Using configuration type 1
Oct 12 23:34:12 host kernel: PCI: Probing PCI hardware
Oct 12 23:34:12 host kernel: PCI: Interrupt Routing Table found at
0xc00fb8b0 [router type 8086/1234]
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 0 of
device 01:05.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 1 of
device 01:05.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 2 of
device 01:05.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 3 of
device 01:05.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 4 of
device 01:05.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 0 of
device 01:07.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 1 of
device 01:07.0
Oct 12 23:34:12 host kernel: PCI: Cannot allocate resource region 0 of
device 01:08.0
Oct 12 23:34:12 host kernel: PCI: Assigned addresses 10000000-10000fff
to region 00:03.0/0
Oct 12 23:34:12 host kernel: PCI: Assigned addresses 10001000-10001fff
to region 00:03.1/0
Oct 12 23:34:12 host kernel: PCI: Cannot find parent resource for device
01:05.0
Oct 12 23:34:12 host atd: atd startup succeeded
Oct 12 23:34:12 host kernel: PCI: Cannot find parent resource for device
01:07.0
Oct 12 23:34:12 host kernel: PCI: Cannot find parent resource for device
01:07.0
Oct 12 23:34:12 host kernel: PCI: Cannot find parent resource for device
01:08.0
[...]
Oct 12 23:34:12 host kernel: Uniform Multi-Platform E-IDE driver
Revision: 6.20
Oct 12 23:34:12 host kernel: PIIX4: IDE controller on PCI bus 00 dev 39
Oct 12 23:34:12 host kernel: PIIX4: not 100% native mode: will probe
irqs later
Oct 12 23:34:12 host kernel: ide0: BM-DMA at 0x0860-0x0867, BIOS
settings: hda:DMA, hdb:pio
Oct 12 23:34:12 host kernel: ide1: BM-DMA at 0x0868-0x086f, BIOS
settings: hdc:pio, hdd:pio
Oct 12 23:34:12 host kernel: CMD646: IDE controller on PCI bus 01 dev 28
Oct 12 23:34:12 host kernel: CMD646: 100% native mode on irq 10
Oct 12 23:34:12 host kernel: CMD646: IO baseregs (BIOS) are reported as
MEM, report to <andre@suse.com>.
Oct 12 23:34:12 host kernel: CMD646: port 0x01f0 already claimed by ide0

Oct 12 23:34:12 host kernel: CMD646: IO baseregs (BIOS) are reported as
MEM, report to <andre@suse.com>.
[...]
Oct 12 23:34:12 host kernel: CMD646: port 0x0170 already claimed by ide1

Oct 12 23:34:12 host kernel: CMD646: neither IDE port enabled (BIOS)
Oct 12 23:34:12 host kernel: hda: IBM-DADA-26480, ATA DISK drive
Oct 12 23:34:12 host kernel: hdc: CD-ROM CDR_U200, ATAPI CDROM drive
[...]
Oct 12 23:34:12 host kernel: A 3Com network adapter has been found,
however it has not been assigned an I/O address.
Oct 12 23:34:12 host kernel: You may need to power-cycle the machine
for this device to work!

Info from /proc/interrupts (under 2.2.13pre16):

CPU0
0: 602457 XT-PIC timer
1: 8557 XT-PIC keyboard
2: 0 XT-PIC cascade
3: 4 XT-PIC 3c589_cs
5: 1 XT-PIC soundblaster
9: 2 XT-PIC i82365
10: 34455 XT-PIC eth0
12: 76564 XT-PIC PS/2 Mouse
13: 1 XT-PIC fpu
14: 15564 XT-PIC ide0
15: 7 XT-PIC ide1
NMI: 0


I would love to help out debugging the 2.3 series, but I can't help much
when the PCI support doesn't work. I am more than willing to provide
further info, run further tests, etc -- whatever anyone wants me to do.




Cheers,

Chris Shutters
cshutters@dmwworldwide.com



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:54    [from the cache]
©2003-2011 Jasper Spaans