lkml.org 
[lkml]   [1999]   [Jan]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: 2.2.0pre1/2.1.132 sound broken

    Hi guys. Sorry for the delay, but I just came back from
    the french alps.

    Michael Krause wrote:
    >
    > On Mon, 28 Dec 1998, Jeff DeFouw wrote:
    >
    > > It appears 2.2.0pre1 (and 2.1.132 after I checked) has a problem recording
    > > from a sound device after playing sound. I'm pretty sure I didn't have
    > > this problem in 2.1.131.
    >
    > This problem was introduced in the 131-ac patches. Some guy added this
    > code:

    I added the code myself to fix a nasty glitch in mmapped sound after
    reopening the device.

    >
    > to the top of sb_audio_close() in sb_audio.c. I suppose it has
    > something to do with the recently added full-duplex support (Daniel
    > J. Rodriksson, cc'ing to him). Commenting this out cures the problem
    > for me; apparently the if() condition is wrong. I had a quick glance
    > at the driver code, but couldn't make out how to fix this properly.

    I'll recheck all conditions.


    --
    |----------------------------------------------------------------|
    | Remember Scotch: 'THERE CAN BE ONLY ONE' |
    |----------------------------------------------------------------|
    | Daniel J. Rodriksson | B-204.1,ETSI Telecomunicaciones |
    | djr@dit.upm.es | Avda Paraninfo S/N |
    | http://www.dit.upm.es/~djr | 28040 Madrid |
    | +34-91-3367366 + ext 442 | SPAIN |
    |----------------------------------------------------------------|

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:49    [W:0.022 / U:0.384 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site