lkml.org 
[lkml]   [1998]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: F00F...
hi,

are all of you really sure you are looking for this bug in the right
place?
I've got a good old P90 here running 2.1.120pre3 and
/proc/cpuinfo gives me (erroneously)

model : Pentium 75+
vendor_id : GenuineIntel
stepping : 1
fdiv_bug : no
hlt_bug : no
sep_bug : no
f00f_bug : no

while I know this machine has a) the f00f and b) the fdiv bug.

On the other hand, the boot-sequence shows

<4>CPU0: Intel Pentium 75+ stepping 01
<5>SMP motherboard not detected. Using dummy APIC emulation.
<6>Checking 386/387 coupling... Hmm, FPU using exception 16 error
reporting with FDIV bug.
<6>Checking 'hlt' instruction... OK.
<6>Intel Pentium with F0 0F bug - workaround enabled.

so the problems are detected, measures taken and I won't worry :-)

I guess it's just the code that gives the values in /proc thats
buggy .... well, sorry but I'm missing the time for a closer look.



with kind regards,
Ruediger Oertel (ro@suse.de)
-----------------------------------------------------------------
:-)) The perfect BIOS-Setup: Chipset -> IDE -> Disable_All :-))
----ALWAYS REMEMBER: WHATEVER I SAY, IT'S MY PERSONAL OPINION----


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.altern.org/andrebalsa/doc/lkml-faq.html

\
 
 \ /
  Last update: 2005-03-22 13:44    [W:0.091 / U:6.692 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site