lkml.org 
[lkml]   [1998]   [Sep]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectthe SCSI way to crash a kernel
Hi all,

don't know whether this is a know Bug...

it is possible to crash the kernel via generic SCSI devices.

Start cdda2wav (for example) and kill it while it tries to come back from
a failed access - till now everything seems ok. But:
*cdda2wav can't be restarted ("Device doesn't support open("/dev/sga")")
*do "ps": there is one cdda2wav-process which can't be killed (status DW)
*"cdwrite --eject --device /dev/sga" sais "no such device" (normally it
simply opens the door

The big-bang: you _can_ open the CDRom and insert a CD with data, now try
to mount it: the kernel halts

-> sorry I don't know whether it panics or simply halts, I worked under X
and don't want to risk my data again

!! I worked as a normal user not as root! I simply gave the group "root"
access to this special device.

Versions:
Linux : 2.0.34
cdda2wav: 0.9beta11 (0.95alpha18 doesn't compile at my station)
mount : 2.7l
glibc : 2.0.6
gcc : 2.7.2.3

Hardware:
Proc. : Pentium 150MHz
SCSI : Adaptec 2940 (aic7 driver)
CDRom : HP 6020 (writer)

Now the big question: is it possible to make the sg-devices more reliable?
They are used for CDDA, scanners and CD-writing which are more typical for
non-root-users ...
Or is it possible to reset single devices to get the waiting processes
back into a killable state? (The SCSI bus resetted automatically but the
process was still there waiting for something.)

happy hacking,
Konrad Rosenbaum

PS.: please Cc your suggestions to htw6966@htw-dresden.de, I am don't
receive this list because of too much traffic on it...

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.altern.org/andrebalsa/doc/lkml-faq.html

\
 
 \ /
  Last update: 2005-03-22 13:44    [W:0.027 / U:6.920 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site