[lkml]   [1998]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: DEVFSv50 and /dev/fb? (or /dev/fb/? ???)
On Fri, 7 Aug 1998, Andrew J. Anderson wrote:

> fact #1:
> fact #2:
> fact #2:
> fact #3:

I agree w/ all of these, even if I count differently. :)

> Similarly, dev_fs may provide the groundwork for the next "great thing",
> perhaps the idea that Ted came up with re: volume names (which being a
> former NetWare admin *does* appeal to me greatly). But the simple fact is
> that dev_fs is here today, Ted's idea is not.

I like this idea quite a bit myself, and am looking forward to
hopefully some code, if I heard correctly I believe he is working on
implementing this...

> Please, there is a great deal of intellegince on this list, let's use it
> for rational discussion, not flaming. There have been some concerns
> brought up about dev_fs:
> * memory consumption

This doesn't appear to be a problem from what I understand...

> * setup/teardown on boot/reboot

My feelings at least on this are that I would like devices to
stay as static as possible between reboots unless a reconfig is
requested by the user, or perhaps if some devices are not found remove
them, but that's debateable. Perhaps a flag for this as well as some
other things such as auto reconfig on boot, module load/unload, if
device nodes should be created for modules that are created and then
the modules attempted to be loaded automagically when that device is
opened, or if device nodes should be created when a module is loaded.

- Auto reconfig on boot
- Auto reconfig on Module loading/unloading
- Device nodes created for all modules that are compiled,
then modules auto-loaded when node opened?
- Device nodes created when modules are loaded?

> * is it necessary for devices with static namespaces? (ide,floppy,serial)

Perhaps for ide since from what I hear IDE is starting to get
somewhat complex. For floppy drives and serial ports I wouldn't think
we would need dev_fs, or at least we don't really need a different
naming convention, since /dev/fd0 and /dev/ttyS00 can be extended almost

I can understand perhaps the need for being able to create new
device nodes on the fly for many things though due to the
many possible uses of USB, so perhaps dev_fs would be usefull there.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:43    [W:0.095 / U:0.028 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site