[lkml]   [1998]   [Jun]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: ___ 2.0.34-pre11 (and pre16 too) /dev/mem broken???
    Philip Blundell <> said:
    > >development glibc v2.1 releases requires gcc-2.8.1. :o( I don't really
    > >want to have to upgrade to gcc-2.8.1 in order to use glibc v2.1, when I
    > >have a perfectly good v2.7.2.3 compiler! Whose *insert your favourite
    > >expletive here* decision was this, and why?

    > It wasn't a deliberate decision. 2.7.2.x has bugs that cause it to
    > miscompile the glibc code.

    And kernels 2.0.xx have bugs that cause _them_ to be miscompiled by
    gcc-2.8.x/egcs ;-)

    > You can install several different versions of gcc and select between them
    > with the -V switch. This may help you. Alternatively, 2.1 kernels seem
    > OK when compiled with gcc 2.8 or egcs.

    I've been using egcs snapshots almost exclusively for some months now,
    compiling lots of 2.1.xx kernels with them (also much userland code) and
    had only minor problems (mostly due to the shakeout of the 2.0.xx bugs
    mentioned above). This here is currently linux-2.1.104-1, compiled with
    egcs-2.91.34 (ss 19980531), glibc-2.0.94 + a patch, binutils- on
    Horst von Brand
    Casilla 9G, Viña del Mar, Chile +56 32 672616

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to

     \ /
      Last update: 2005-03-22 13:42    [W:0.019 / U:31.308 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site