lkml.org 
[lkml]   [1998]   [Feb]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectlinux-2.1.89-pre2 - sound on sb-non-module - int probs ?
Just as in 2.1.88, linux-2.1.89-pre2 still has sound problems with sb
when compiled in the kernel (haven't checked module.)

The sound comes in small packets. sound starts... wait... sound
continues... wait... sound continues... (repeat)

The syslog_kern says:

kernel: sb: Interrupt test on IRQ7 failed - Probable IRQ con
kernel: <Sound Blaster 16 (4.13)> at 0x220 irq 7 dma 1,5
kernel: <Sound Blaster 16> at 0x330 irq 7 dma 0
kernel: <Yamaha OPL3 FM> at 0x388


but I'm SURE there's nothing on IRQ 7. In all previous versions of
Linux it's worked just fine at that IRQ.

# lsdev
Device DMA IRQ Ports
------------------------------------------------
3c509 10 0300-030f
cascade 4 2
dma 0080-008f
dma1 0000-001f
dma2 00c0-00df
fpu 13 00f0-00ff
ide0 14 01f0-01f7 03f6-03f6 ffa0-ffa7
ide1 15 0170-0177 0376-0376 ffa8-ffaf
keyboard 1 0060-006f
MPU-401 0330-0333
OPL3/OPL2 0388-038b
pic1 0020-003f
pic2 00a0-00bf
PS/2 12
soundblaster 7 0220-022f
SoundBlaster16 5
SoundBlaster8 1
timer 0 0040-005f
vga+ 03c0-03df
# cat /dev/sndstat
OSS/Free:3.8s2++-971130
Load type: Driver compiled into kernel
Kernel: Linux bs1 2.1.89 #1 Thu Feb 26 11:48:14 CST 1998 i586
Config options: 0

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 26: MPU-401 (UART)
Type 2: Sound Blaster
Type 29: Sound Blaster PnP
Type 7: SB MPU-401

Card config:
Sound Blaster at 0x220 irq 7 drq 1,5
SB MPU-401 at 0x330 irq 7 drq 0
OPL-2/OPL-3 FM at 0x388 drq 0

Audio devices:
0: Sound Blaster 16 (4.13)

Synth devices:
0: Yamaha OPL-3

Midi devices:
0: Sound Blaster 16
Timers:
0: System clock

Mixers:
0: Sound Blaster



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu

\
 
 \ /
  Last update: 2005-03-22 13:41    [from the cache]
©2003-2011 Jasper Spaans