[lkml]   [1998]   [Feb]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: quake server / 2.1.8x / UDP?
    > Somewhere between 2.1.56 and 2.1.85, my quake server (squake -listen and
    > squake -dedicated) stopped working.
    > About the only other detail I know is that quake uses UDP.
    > When I try to connect to the server from localhost or another machine (in
    > 2.1.8[567] only), it says "Trying..." several times, then quits. In
    > 2.1.56, it finds the host immediately.
    > This is SMP, Tyan S1668 dual PPRO, 64MB, de205 isa ethernet (ewrk3
    > driver, module), only non-default networking option = IP accounting
    > Compiled: pgcc-2.91.02 971216 (gcc-2.8.0)
    > (also tried 2.1.87 no SMP gcc same result)

    I've been experiencing this too. Running "netstat -au" shows the

    Active Internet connections (including servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    udp 2654 0 *:26000 *:*

    (of course, the data in Recv-Q varies depending on how many times I've
    tried to connect)

    > Suggestions?

    I found that reversing the patch to udp.c from 2.1.73 cures the problem
    for me, although I'm not enough of a guru to understand why. I'd be
    happy to try out a more proper fix.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to

     \ /
      Last update: 2005-03-22 13:41    [W:0.023 / U:3.388 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site