lkml.org 
[lkml]   [1998]   [Nov]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: ppp and 2.1.126/2.1.125
    On Mon, 2 Nov 1998, Matthias Andree wrote:

    > On Sun, Nov 01, 1998 at 09:47:08AM -0500, flewid wrote:
    > > Hi, i have tried installing 2.1.126, and then tried using ppp, and it did
    > > not work, it dials my ISP, then doesnt resolv my ip's for some reason, it
    > > just sits there and then hangs up, what is weird is, im using the exact
    > > same configureation for 2.0.35, and it works just fine.

    <snip>

    > > i haven't a clue as to what is causing this, is there
    > > something im forgetting to do? please feel free to tell me :)
    >
    > With 2.1.125, pppd is fine IF it is patched to NOT bail out if it
    > cannot set the route. (This is needed to break the chain "link not up"
    > <-> "cannot set route": pppd lets ppp? come up only after setting the
    > default route while linux 2.1.125 lets the route be set only after the
    > device has come up). There are patches, I do not remember where, search
    > the archives.

    /usr/src/linux/Documentation/networking/ppp.txt has the patch which
    applies to 2.2.0f, and with a tiny bit of massaging to 2.3.3 (as
    supplied with Redhat, f'r instance).

    Patched Redhat 5.1 based rpms/srpms/sources/specs for ppp-2.3.3 are
    available here:

    ftp://pc24.sr.bham.ac.uk/pub/packages/RPMS/i386/ppp-2.3.3-4mc2.i386.rpm
    ftp://pc24.sr.bham.ac.uk/pub/packages/SRPMS/ppp-2.3.3-4mc2.src.rpm

    +-------------------------------------------------------------------------+
    Mark Cooke The views expressed above are mine and are not
    Systems Programmer necessarily representative of university policy
    University Of Birmingham URL: http://www.sr.bham.ac.uk/~mpc/
    +-------------------------------------------------------------------------+


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:45    [W:0.020 / U:1.232 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site