lkml.org 
[lkml]   [1998]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: schedule_timeout: wrong timeout value ffffff9f from c012bb75
I get this as well.
Except, it only occurs at one time.
Whenever i try to mount my desktop by NFS from my laptop, i get this
spewed all over my screen now (my desktop this is), and it's hung.
It doesn't ever crash, just prints this until i turn the damn computer
off.
I've left it for hours just to see if anything came of it, and besides the
timeout value decreasing (the from never changes), nothing.
Funny thing is, it's correct. At least, methinks.
No process is getting any time, or any real amount.
Cause i can telnet to ftp, telnet, www, etc, and the connection gets
made, but nothing ever comes over the wire from those ports.
I can't shutdown, can't halt, can't do crap.
At least, in user land.
It seems to still process other things, like disk writes.
Cause even if i'm copying 100 meg files and deleting tons o'crap when i
try to mount it from my laptop, and the hangup starts, if i leave it for a
few minutes, shutoff, and restart, nothing is ever bad in the file system,
not a single inode.
This is completely a 2.1.127 problem.
I've tried ac1 as well (fails), as well as the vger tree(works for the
126 as of about 1 hour before 127 was in there), and the normal 126
(works).
I've gone back to 126 for now.
--Dan
On Tue, 10 Nov 1998, Mike Sackton wrote:

> Recently upgraded from 2.1.126 to 2.1.127, and
> started getting:
>
> Nov 10 11:40:33 isaac kernel: schedule_timeout: wrong timeout value
> ffffff9f from c012bb75
>
> every 2 - 5 seconds. The timeout values change around a bit, but are
> never less than ffffff00. I c012bb75 wasn't in my System.map though, so
> I'm not really sure how to go about finding what is causing the problem. I
> am using modules, but the error message keeps coming even if I unload all
> the modules. Nothing on my system *seems* to be negatively affected. The
> messages started around 04:00 EST, and haven't stopped yet. My system has
> only been up about 20 hours, so far.
>
> .config:
>
> #
> # Automatically generated by make menuconfig: don't edit
> #
>
> #
> # Code maturity level options
> #
> CONFIG_EXPERIMENTAL=y
>
> #
> # Processor type and features
> #
> # CONFIG_M386 is not set
> # CONFIG_M486 is not set
> CONFIG_M586=y
> # CONFIG_M686 is not set
> # CONFIG_MATH_EMULATION is not set
> # CONFIG_MTRR is not set
>
> #
> # Loadable module support
> #
> CONFIG_MODULES=y
> CONFIG_MODVERSIONS=y
> CONFIG_KMOD=y
>
> #
> # General setup
> #
> CONFIG_NET=y
> CONFIG_PCI=y
> CONFIG_PCI_BIOS=y
> CONFIG_PCI_DIRECT=y
> CONFIG_PCI_QUIRKS=y
> # CONFIG_PCI_OPTIMIZE is not set
> CONFIG_PCI_OLD_PROC=y
> # CONFIG_MCA is not set
> CONFIG_SYSVIPC=y
> CONFIG_BSD_PROCESS_ACCT=y
> CONFIG_SYSCTL=y
> CONFIG_BINFMT_AOUT=m
> CONFIG_BINFMT_ELF=y
> CONFIG_BINFMT_MISC=m
> # CONFIG_BINFMT_JAVA is not set
> CONFIG_PARPORT=y
> CONFIG_PARPORT_PC=y
> # CONFIG_PARPORT_OTHER is not set
> # CONFIG_APM is not set
>
> #
> # Plug and Play support
> #
> CONFIG_PNP=y
> CONFIG_PNP_PARPORT=m
>
> #
> # Block devices
> #
> CONFIG_BLK_DEV_FD=y
> CONFIG_BLK_DEV_IDE=y
> # CONFIG_BLK_DEV_HD_IDE is not set
> CONFIG_BLK_DEV_IDEDISK=y
> CONFIG_BLK_DEV_IDECD=m
> # CONFIG_BLK_DEV_IDETAPE is not set
> CONFIG_BLK_DEV_IDEFLOPPY=m
> # CONFIG_BLK_DEV_IDESCSI is not set
> # CONFIG_BLK_DEV_CMD640 is not set
> # CONFIG_BLK_DEV_RZ1000 is not set
> CONFIG_BLK_DEV_IDEPCI=y
> CONFIG_BLK_DEV_IDEDMA=y
> # CONFIG_BLK_DEV_OFFBOARD is not set
> CONFIG_IDEDMA_AUTO=y
> # CONFIG_BLK_DEV_OPTI621 is not set
> # CONFIG_BLK_DEV_TRM290 is not set
> # CONFIG_BLK_DEV_NS87415 is not set
> # CONFIG_BLK_DEV_VIA82C586 is not set
> # CONFIG_BLK_DEV_CMD646 is not set
> # CONFIG_IDE_CHIPSETS is not set
> CONFIG_BLK_DEV_LOOP=m
> CONFIG_BLK_DEV_NBD=m
> # CONFIG_BLK_DEV_MD is not set
> # CONFIG_BLK_DEV_RAM is not set
> # CONFIG_BLK_DEV_XD is not set
> CONFIG_PARIDE_PARPORT=y
> # CONFIG_PARIDE is not set
> # CONFIG_BLK_DEV_HD is not set
>
> #
> # Networking options
> #
> CONFIG_PACKET=y
> # CONFIG_NETLINK is not set
> # CONFIG_FIREWALL is not set
> # CONFIG_NET_ALIAS is not set
> # CONFIG_FILTER is not set
> CONFIG_UNIX=y
> CONFIG_INET=y
> CONFIG_IP_MULTICAST=y
> # CONFIG_IP_ADVANCED_ROUTER is not set
> # CONFIG_IP_PNP is not set
> # CONFIG_IP_ROUTER is not set
> # CONFIG_NET_IPIP is not set
> # CONFIG_NET_IPGRE is not set
> # CONFIG_IP_MROUTE is not set
> # CONFIG_IP_ALIAS is not set
> CONFIG_SYN_COOKIES=y
> # CONFIG_INET_RARP is not set
> CONFIG_IP_NOSR=y
> CONFIG_SKB_LARGE=y
> # CONFIG_IPV6 is not set
> # CONFIG_IPX is not set
> # CONFIG_ATALK is not set
> # CONFIG_X25 is not set
> # CONFIG_LAPB is not set
> # CONFIG_BRIDGE is not set
> # CONFIG_LLC is not set
> # CONFIG_ECONET is not set
> # CONFIG_WAN_ROUTER is not set
> # CONFIG_NET_FASTROUTE is not set
> # CONFIG_NET_HW_FLOWCONTROL is not set
> # CONFIG_CPU_IS_SLOW is not set
> # CONFIG_NET_SCHED is not set
>
> #
> # SCSI support
> #
> # CONFIG_SCSI is not set
>
> #
> # Network device support
> #
> CONFIG_NETDEVICES=y
> # CONFIG_ARCNET is not set
> CONFIG_DUMMY=m
> # CONFIG_EQUALIZER is not set
> CONFIG_NET_ETHERNET=y
> CONFIG_NET_VENDOR_3COM=y
> # CONFIG_EL1 is not set
> # CONFIG_EL2 is not set
> # CONFIG_ELPLUS is not set
> # CONFIG_EL16 is not set
> CONFIG_EL3=y
> CONFIG_VORTEX=y
> # CONFIG_LANCE is not set
> # CONFIG_NET_VENDOR_SMC is not set
> # CONFIG_NET_VENDOR_RACAL is not set
> # CONFIG_RTL8139 is not set
> # CONFIG_YELLOWFIN is not set
> # CONFIG_NET_ISA is not set
> # CONFIG_NET_EISA is not set
> # CONFIG_NET_POCKET is not set
> # CONFIG_FDDI is not set
> # CONFIG_HIPPI is not set
> # CONFIG_DLCI is not set
> # CONFIG_PLIP is not set
> # CONFIG_PPP is not set
> # CONFIG_SLIP is not set
> # CONFIG_NET_RADIO is not set
> # CONFIG_TR is not set
> # CONFIG_SHAPER is not set
> # CONFIG_HOSTESS_SV11 is not set
>
> #
> # Amateur Radio support
> #
> # CONFIG_HAMRADIO is not set
>
> #
> # ISDN subsystem
> #
> # CONFIG_ISDN is not set
>
> #
> # CD-ROM drivers (not for SCSI or IDE/ATAPI drives)
> #
> # CONFIG_CD_NO_IDESCSI is not set
>
> #
> # Character devices
> #
> CONFIG_VT=y
> CONFIG_VT_CONSOLE=y
> CONFIG_SERIAL=y
> # CONFIG_SERIAL_CONSOLE is not set
> # CONFIG_SERIAL_EXTENDED is not set
> # CONFIG_SERIAL_NONSTANDARD is not set
> CONFIG_UNIX98_PTYS=y
> CONFIG_UNIX98_PTY_COUNT=256
> CONFIG_PRINTER=y
> CONFIG_PRINTER_READBACK=y
> CONFIG_MOUSE=y
> # CONFIG_ATIXL_BUSMOUSE is not set
> # CONFIG_BUSMOUSE is not set
> # CONFIG_MS_BUSMOUSE is not set
> CONFIG_PSMOUSE=y
> # CONFIG_82C710_MOUSE is not set
> # CONFIG_PC110_PAD is not set
> # CONFIG_QIC02_TAPE is not set
> # CONFIG_WATCHDOG is not set
> CONFIG_RTC=y
> # CONFIG_VIDEO_DEV is not set
> CONFIG_NVRAM=m
> # CONFIG_JOYSTICK is not set
>
> #
> # Ftape, the floppy tape device driver
> #
> # CONFIG_FTAPE is not set
>
> #
> # Filesystems
> #
> # CONFIG_QUOTA is not set
> # CONFIG_MINIX_FS is not set
> CONFIG_EXT2_FS=y
> CONFIG_ISO9660_FS=m
> # CONFIG_JOLIET is not set
> CONFIG_FAT_FS=y
> CONFIG_MSDOS_FS=y
> # CONFIG_UMSDOS_FS is not set
> CONFIG_VFAT_FS=y
> CONFIG_PROC_FS=y
> CONFIG_NFS_FS=m
> CONFIG_NFSD=m
> # CONFIG_NFSD_SUN is not set
> CONFIG_SUNRPC=m
> CONFIG_LOCKD=m
> # CONFIG_CODA_FS is not set
> # CONFIG_SMB_FS is not set
> # CONFIG_HPFS_FS is not set
> # CONFIG_NTFS_FS is not set
> # CONFIG_SYSV_FS is not set
> # CONFIG_AFFS_FS is not set
> CONFIG_HFS_FS=m
> # CONFIG_ROMFS_FS is not set
> # CONFIG_AUTOFS_FS is not set
> # CONFIG_UFS_FS is not set
> # CONFIG_BSD_DISKLABEL is not set
> # CONFIG_SMD_DISKLABEL is not set
> # CONFIG_SOLARIS_X86_PARTITION is not set
> CONFIG_DEVPTS_FS=y
> # CONFIG_ADFS_FS is not set
> # CONFIG_QNX4FS_FS is not set
> # CONFIG_MAC_PARTITION is not set
> CONFIG_NLS=y
>
> #
> # Native Language Support
> #
> CONFIG_NLS_CODEPAGE_437=m
> # CONFIG_NLS_CODEPAGE_737 is not set
> # CONFIG_NLS_CODEPAGE_775 is not set
> # CONFIG_NLS_CODEPAGE_850 is not set
> # CONFIG_NLS_CODEPAGE_852 is not set
> # CONFIG_NLS_CODEPAGE_855 is not set
> # CONFIG_NLS_CODEPAGE_857 is not set
> # CONFIG_NLS_CODEPAGE_860 is not set
> # CONFIG_NLS_CODEPAGE_861 is not set
> # CONFIG_NLS_CODEPAGE_862 is not set
> # CONFIG_NLS_CODEPAGE_863 is not set
> # CONFIG_NLS_CODEPAGE_864 is not set
> # CONFIG_NLS_CODEPAGE_865 is not set
> # CONFIG_NLS_CODEPAGE_866 is not set
> # CONFIG_NLS_CODEPAGE_869 is not set
> # CONFIG_NLS_CODEPAGE_874 is not set
> CONFIG_NLS_ISO8859_1=m
> # CONFIG_NLS_ISO8859_2 is not set
> # CONFIG_NLS_ISO8859_3 is not set
> # CONFIG_NLS_ISO8859_4 is not set
> # CONFIG_NLS_ISO8859_5 is not set
> # CONFIG_NLS_ISO8859_6 is not set
> # CONFIG_NLS_ISO8859_7 is not set
> # CONFIG_NLS_ISO8859_8 is not set
> # CONFIG_NLS_ISO8859_9 is not set
> # CONFIG_NLS_KOI8_R is not set
>
> #
> # Console drivers
> #
> CONFIG_VGA_CONSOLE=y
> CONFIG_VIDEO_SELECT=y
> # CONFIG_MDA_CONSOLE is not set
> # CONFIG_FB is not set
>
> #
> # Sound
> #
> CONFIG_SOUND=m
> # CONFIG_SOUND_ES1370 is not set
> # CONFIG_SOUND_ES1371 is not set
> # CONFIG_SOUND_SONICVIBES is not set
> # CONFIG_SOUND_MSNDCLAS is not set
> # CONFIG_SOUND_MSNDPIN is not set
> CONFIG_SOUND_OSS=m
> # CONFIG_SOUND_PAS is not set
> # CONFIG_SOUND_SB is not set
> # CONFIG_SOUND_ADLIB is not set
> # CONFIG_SOUND_GUS is not set
> CONFIG_SOUND_MPU401=m
> # CONFIG_SOUND_PSS is not set
> # CONFIG_SOUND_MSS is not set
> # CONFIG_SOUND_SSCAPE is not set
> # CONFIG_SOUND_TRIX is not set
> # CONFIG_SOUND_MAD16 is not set
> # CONFIG_SOUND_WAVEFRONT is not set
> # CONFIG_SOUND_CS4232 is not set
> CONFIG_SOUND_OPL3SA2=m
> # CONFIG_SOUND_MAUI is not set
> # CONFIG_SOUND_SGALAXY is not set
> # CONFIG_SOUND_OPL3SA1 is not set
> # CONFIG_SOUND_SOFTOSS is not set
> # CONFIG_SOUND_YM3812 is not set
> # CONFIG_SOUND_VMIDI is not set
> # CONFIG_SOUND_UART6850 is not set
>
> #
> # Additional low level sound drivers
> #
> # CONFIG_LOWLEVEL_SOUND is not set
>
> #
> # Kernel hacking
> #
> CONFIG_MAGIC_SYSRQ=y
>
>
> --
> "Only wimps use tape backup: _real_ men just upload their important stuff
> on ftp, and let the rest of the world mirror it ;)"
> --(Linus Torvalds, about his failing hard drive on linux.cs.helsinki.fi)
>
>
>
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.rutgers.edu
> Please read the FAQ at http://www.tux.org/lkml/
>


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:45    [from the cache]
©2003-2011 Jasper Spaans