lkml.org 
[lkml]   [1997]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: pre-5 Aiih!
On Thu, 14 Aug 1997, Doug Ledford wrote:
> > When using the aic7xxx with 31 tagged commands, I sometimes get timeouts
> > resulting in 'Aiih's. This is very annoying if I had a crash and 'e2fsck'
> > craches over and over again...
> >
> > Using just 8 tagged commands seems to work fine. Where can I adjust these
> > timeouts?
>
> You may want to listen in to the mailings on aic7xxx@freebsd.org. As it
> stands I'm in the middle of writing a patch to fix the abort/reset
> processing as well as it adds a bottom half handler to the interrupt service
> routine to avoid high latencies in the interrupt processing that can result
> in the QOUTFIFO over flowing. Dan Eischen has already released one fix for
> the QOUTFIFO overflow problem (sent to Linus just a few days ago), but it is
> a spin lock and somewhat less elegant from the standpoint that it doesn't
> actually solve the latency problem. The final code will probably have my
> bottom half handler as well as the safety of a spin lock backup both in
> there. I'm also doing what I can to make sure we aren't getting bogus
> information from anyplace, which would result in the Aiee: type messages you
> mention. I expect to have the first publically available abort/reset fixes
> available for testing by either late tonight or sometime tomorrow.

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: SANYO Model: CRD-254S Rev: 1.02
Type: CD-ROM ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
Vendor: CONNER Model: CFP4207S 4.28GB Rev: 1524
Type: Direct-Access ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 06 Lun: 00
Vendor: MICROP Model: 1598-15MD1084001 Rev: SIH0
Type: Direct-Access ANSI SCSI revision: 01 CCS

Adaptec AIC7xxx driver version: 4.1/3.2
Compile Options:
AIC7XXX_RESET_DELAY : 3
AIC7XXX_CMDS_PER_LUN : 31
AIC7XXX_TAGGED_QUEUEING: Enabled
AIC7XXX_PAGE_ENABLE : Enabled
AIC7XXX_PROC_STATS : Enabled

Adapter Configuration:
SCSI Adapter: Adaptec AIC-7870 SCSI host adapter
(AIC-787x chipset)
Host Bus: Wide
Base IO: 0xe400
Base IO Memory: 0xfbfdf000
IRQ: 12
SCBs: Used 8, HW 16, Page 255
Interrupts: 32493
Serial EEPROM: True
Extended Translation: Enabled
SCSI Bus Reset: Enabled
Ultra SCSI: Disabled
Target Disconnect: Enabled

I guess the bad device is the Micropolis. I had some 'queue full' with 32
tagged commands on my Conner, so I reduced it to 31. The Micropolis is not
used very often, had no 'queue full', but I didn't want to test it...

The Aiih was in different locations, e2fsck, swapper, etc. and happened
while fscking the disks after an unclean shutdown, so I guess I could
repeat it as often as I want...but maybe in 'read-only'-mode...there was
nothing to fix because I had not accessed the disks.

One nice enhancement would be to allow different depths of tagged queues
on each device/lun.

I heard from the Quantum drives that need a firmware upgrate from
ftp.quantum.com (it's not on their webserver :-( )

Does there is a possibility to intentionally reset the scsi-bus, e.g. via

echo "scsi reset 0 0" > /proc/scsi

I tried to implement it, but it kept resetting the bus. The reason for
this are hot-pluggable disks...Yes, I have on of those frames that allow
hot-plugging of disks and that halt the scsi-bus while inserting. I tried
it and it worked fine iff I used 'scsi-rescan'.

Please send me any fixes and I'll test them.

Kurt

-------------------------------------------------------------
Impossible doesn't exist! Unmöglich gibt's nicht!
Difficult exists. Schwierig gibt's.


\
 
 \ /
  Last update: 2005-03-22 13:40    [W:0.049 / U:7.464 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site