lkml.org 
[lkml]   [1997]   [Jun]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectTx request while isr active.

With 2.1.43 i still get those messages scrolling over my screen and lockup on
my SMP box with 2 ethernet cards. (WD8013 + SMC Ultra) I always had these
lockups since about 2.1.31.

Per Linus request (back in April, 2.1.3[1234] days) i tried adding
synchronize_irq() calls in 8390.c after the lines where IRQs from the card has
been disabled and it seemed to help (i.e. i can't lockup the machine with two
simultanious ping -f and the machine was running for more than 24 hours) but i
still was getting

eth0: Interrupted while interrupts are masked! isr=0x1 imr=0x0.
eth1: Interrupted while interrupts are masked! isr=0x2 imr=0x0.

and i know that my 'fix' is far from beeing complete. The machine was locked
hard this morning. (i can't check that it was the same lockup as before)


Gyula
--
Matics, Gyula
mgyula@eik.bme.hu Linux!




\
 
 \ /
  Last update: 2005-03-22 13:39    [W:0.019 / U:1.836 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site