lkml.org 
[lkml]   [1997]   [Apr]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectmounted partition morhpes with 2.0.28 ?
I've encountered a weird problem which only happens on one of
our machiens with two partions on an IDE harddisk.

/vol/bigfoot> df
Filesystem 1024-blocks Used Available Capacity Mounted on
/dev/hda3 938517 577034 312999 65% /
/dev/hda2 50749 460 47669 1% /tmp
/dev/hdb2 1938488 1347844 490449 73% /vol
/dev/hdb1 1938488 1347844 490449 73% /vol/bigfoot
bean:/usr/local 497667 374233 97732 79% /usr/local
bean:/var/spool/mail 497667 323059 148906 68% /var/spool/mail
bean:/var/spool/fax 497667 323059 148906 68% /var/spool/fax
bean:/vol/staff 497667 163016 308949 35% /vol/staff

Notice hdb1 and hdb2.

/etc/fstab has:
/dev/hdb2 /vol ext2 exec,dev,suid, usrquota=/cnf/quota/root-usr.quota,grpquota=/cnf/quota/root-grp.quota 1 1
/dev/hdb1 /vol/bigfoot ext2 defaults 1 1

/etc/mtab has:
/dev/hdb2 /vol ext2 rw 0 1
/dev/hdb1 /vol/bigfoot ext2 rw 1 1

Unmouting:
~>umount /dev/hdb1
umount: only root can unmount /dev/hdb1 from /vol/bigfoot
~> su
Password:
# umount /vol/bigfoot
umount: /dev/hdb1: not mounted
# mount /vol/bigfoot
mount: /dev/hdb1 already mounted or /vol/bigfoot busy

Now the mtab entry is gone, but somehow the device is still unmountable.

This problem now occured about three times, and seems to happen while the
machine is up. I am using mount-2.5l

Paul


\
 
 \ /
  Last update: 2005-03-22 13:39    [from the cache]
©2003-2011 Jasper Spaans