[lkml]   [1997]   [Feb]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 2.0.2[79]: aha1740 still doesn't work as module
On Sat, 15 Feb 1997, Klaus Kudielka wrote:

> Hello,
> I just wanted to upgrade my machine to Red Hat 4.1 (bootdisk has
> 2.0.27), but discovered that the Adaptec 1740 driver still does not work
> correctly as a module. When insmod'ed, it detects seven disks (id 0 to
> id 7) with bogus (i.e. null) device information, although there is only
> one disk present (id 0). Even on disk 0 there are no partitions detected
> (although they are here -- Red Hat 4.0 runs quite nicely with 2.0.27 and
> the compiled-in driver).


> Questioins/Suggestions:
> (1) Does anybody know a fix?
> (2) If not, it should not be allowed to compile the driver as a module.

No, I can't help here. However, when someone really gets to work on this,
please get in contact with me, because:

a) I've patches from Andreas Arens which allows the use of multiple
aha174x cards in a machine and extended translation for large disks
(not required for linux but nice to have DOS/linux understand each
other) plus some cosmetical fixups.
I fail to email Andreas Arens, probably he lost connection to the
internet, the patches are well tested but not yet part of the official
kernel and need some work becuase other things were fixed on the 174x

b) Tiny, (< 10 lines) fixes are required to make the driver not warn about
theoretically 'impossible' timeouts on extremely fast new machines.

I tried doing these myself, but obviously lack the time currently.


( or
Please do not use my vm or de0hrz1a accounts anymore. In case of real
problems reaching me try instead.)

 \ /
  Last update: 2005-03-22 13:38    [W:0.039 / U:5.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site