[lkml]   [1997]   [Feb]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectApplication Network bug decryption request

I have a program over here called Nelsis, which is a CAD setup. They
released a Linux version, which apparently worked, but won't here.
Unfortunately, they also didn't release source (growl).

I'm assuming this is a problem with either my kernel configuration, or an
incompatability between the new kernel and a previous one. I'm running
2.1.26 right now, though this has happened all through the 2.1 series.
I've always run into this bug, so I'm just assuming they didn't release
non-functional software in the first place.

There is supposed to be a daemon running in the background called dmpd,
which accepts network connections. I straced the daemon when I ran the
client programs on another VT. This is what I get:

write(4, "DMPD: [RcErrorClass:50] Error cl"..., 77) = 77
send(6, "\0\0\0\1\0\0\0\0\0\0\0\1\0\0\0\1"..., 1024, 0) = 1024
getsockopt(6, SOL_SOCKET, 0 /* SO_??? */, 0, 0xbffffb7c) = -1 ENOPROTOOPT
(Protocol not available)
close(6) = 0

Can someone explain what protocol it's trying to access which isn't
available, and how I can fix it? It ticks me off they didn't release
source so I could fix it, but when I mail them a bug report about it it
would probably be a good idea to have some clue how to fix it.

"Things fall apart; the centre cannot hold. Mere anarchy is loosed upon the
world; The blood-dimmed tide is loosed, and everywhere the ceremony of
innocence is drowned; The best lack all conviction, while the worst are full
of passionate intensity." -- "Second Coming" by Yeats.

 \ /
  Last update: 2005-03-22 13:38    [W:0.082 / U:0.824 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site