[lkml]   [1997]   [Feb]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectLinux hoses floppy drive.
I have a Hitachi C120T notebook computer that I am trying to install linux
on (Red Hat). The first floppy boots fine, but it can't read the next
floppy or any other floppies until the system is _turned_off_ and turned
on again. If I do a soft reboot and start Windows 95, it can't read the
floppy either (until I cycle the power). Linux gives the following error

floppy0: probe failed

This problem is not Red Hat specific, it also happens if I just create a
boot floppy (2.0.2x). As long as the diskette is left in the drive, linux
can still read it, but if it is just ejected and then popped back in, then
linux can no longer read it, failing with the above error message.
Basically, once linux has tried to access a newly installed floppy, the
drive won't work again until the system is turned off and on.

Note that the drive does spin when it is accessed, but the head doesn't
seem to move at all (just listening to it).

It seems that somehow linux is disabling the floppy drive head. I have
tried many different floppies, so this is not a diskette problem. Also
Windows 95 has no problem reading multiple successive floppies, so the
floppy drive isn't broken.

Has anyone else seen this problem, or am I the first one to try to install
linux on the Hitachi C120T? If anyone can suggest a patch or some flags I
might be able to set in floppy.c, that would be great.



 \ /
  Last update: 2005-03-22 13:38    [W:0.024 / U:4.904 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site