[lkml]   [1997]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectUnresolved symbols in /lib/modules/.../*.o?

Tried sending this to linux-newbie, but I haven't gotten an
answer from there. Thought I'd ask here.

I recompiled my kernel (2.0.18, Redhat) and now get a bunch of
complaints upon boot. Something along the lines of:

Finding module dependencies
Unresolved symbols in /lib/modules/2.0.18/yadda/yadda.o

where "yadda" corresponds to quite a few file/directory names.

I haven't added any patches to the kernel, so the version is the
same. I've tried doing a number of other things (make modules, make
modules_install)...without luck.

Anyone have any ideas what I'm missing?


Peter seems that all the linux kernel docs I've found are either
extremely simplified (ie. saying "yes" here does this...), or
kernel-hacking. Anyone know of anything in-between for a non-programmer
who wants to get into programming/kernel stuff?

Thanks again...

/\_/\ |
( o.o ) | (Lizard Ho!!!)
> < |

 \ /
  Last update: 2005-03-22 13:38    [W:0.023 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site