lkml.org 
[lkml]   [1997]   [Nov]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Subjectext2fs or IDE bug in 2.0.31
From
Date
Dear Sirs,

I have found a reproducable bug in Linux 2.0.31. When copying a large
file (140 megabytes) from an ext2fs partition from one hard disk to an
ext2fs partition to another disk (tried it both as /dev/hdb3 and as
/dev/hdc3), the system will hang. Usually it hanged after 60-70
megabytes, but once it hanged at 15-20 megabytes. The system also
hanged when I tried to fetch the file directly from the net to the
/dev/hdb3 or /dev/hdc3 partition. Once I got the following message on
the console:

Kernel panic: skput:over: 00191fa8:246
In swapper task - not syncing

Turning off the swap did not help anything.

Copying the file went without problems with the 2.0.30 kernel.
Unfortunately I don't have any experience in kernel hacking and bug
hunting, so I cannot tell you whether the bug is in the IDE or in the
ext2fs code.

My system is: P75 with 32MB RAM, 1GB IDE hard disk, and the second
disk was 1,7GB IDE, tried as primary slave and secondary master. As I
haven't faced any problems with this setup before, I'm fairly
confident that this is not a hardware problem, but something in the
ext2fs code or in the IDE driver. I'm glad to provide more
information if needed.


With best regards,

Marko Mäkelä

\
 
 \ /
  Last update: 2005-03-22 13:40    [W:0.017 / U:7.296 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site